CVE-2024-40971: f2fs: remove clear SB_INLINECRYPT flag in default_options

Published Jul 12, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

f2fs: remove clear SBINLINECRYPT flag in defaultoptions

In f2fsremount, SBINLINECRYPT flag will be clear and re-set. If create new file or open file during this gap, these files will not use inlinecrypt. Worse case, it may lead to data corruption if wrappedkeyv0 is enable.

Thread A: Thread B:

-f2fsremount -f2fsfileopen or f2fsnewinode -defaultoptions <- clear SBINLINECRYPT flag

-fscryptselectencryptionimpl

-parseoptions <- set SBINLINECRYPT again

Affected Software

9 affected componentsFixes available
Linux Linux kernel>=3.8<5.10.221
Linux Linux kernel>=5.11<5.15.162
Linux Linux kernel>=5.16<6.1.96
Linux Linux kernel>=6.2<6.6.36
Linux Linux kernel>=6.7<6.9.7
debian/linux<6.1.99-1
6.1.99-1
debian/linux<6.9.7-1
6.9.7-1
debian/linux<6.9.7-1
6.9.7-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.99-1
  2. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.9.7-1
  3. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1

Event History

Jul 12, 2024
CVE Published
via MITRE·12:32 PM
Data Sourced
via MITRE·12:32 PM
DescriptionSeverity
Data Sourced
via NVD·01:15 PM
RemedyDescriptionSeverityAffected Software
Data Sourced
via OSV·01:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-40971?

CVE-2024-40971 is classified as a moderate severity vulnerability.

2

How do I fix CVE-2024-40971?

To fix CVE-2024-40971, upgrade the Linux kernel to one of the following versions: 5.10.223-1, 5.10.226-1, 6.1.123-1, 6.1.128-1, 6.12.12-1, or 6.12.13-1.

3

Which Linux kernel versions are affected by CVE-2024-40971?

CVE-2024-40971 affects multiple versions of the Linux kernel before the patches are applied.

4

What are the implications of CVE-2024-40971?

The implications of CVE-2024-40971 include potential file operations failing to use inline encryption during specific remount operations.

5

Is CVE-2024-40971 specific to certain Linux distributions?

CVE-2024-40971 is specifically addressed in Debian's Linux packages, including linux and linux-6.1.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203