CVE-2024-40994: ptp: fix integer overflow in max_vclocks_store

Published Jul 12, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

ptp: fix integer overflow in maxvclocksstore

On 32bit systems, the "4 max" multiply can overflow. Use kcalloc() to do the allocation to prevent this.

Affected Software

14 affected componentsFixes available
Linux Linux kernel>=5.14<5.15.162
Linux Linux kernel>=5.16<6.1.96
Linux Linux kernel>=6.2<6.6.36
Linux Linux kernel>=6.7<6.9.7
Linux Linux kernel=6.10-rc1
Linux Linux kernel=6.10-rc2
Linux Linux kernel=6.10-rc3
Linux Linux kernel=6.10-rc4
Microsoft azl3 kernel 6.6.35.1-5
Microsoft azl3 kernel 6.6.47.1-1
debian/linux<6.1.99-1
6.1.99-1
debian/linux<6.9.7-1
6.9.7-1
debian/linux<6.9.7-1
6.9.7-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.99-1
  2. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.9.7-1
  3. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1
  4. Compensating control

    In the Linux kernel PTP max_vclocks_store implementation, use kcalloc() for the allocation to prevent the integer overflow in the 4 * max multiplication on 32-bit systems.

Event History

Jul 12, 2024
CVE Published
via MITRE·12:37 PM
Data Sourced
via MITRE·12:37 PM
Description
Data Sourced
via NVD·01:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·01:15 PM
DescriptionSeverityAffected Software
Sep 11, 2024
Data Sourced
via Microsoft·07:00 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-40994?

CVE-2024-40994 is considered a medium severity vulnerability affecting the Linux kernel.

2

How do I fix CVE-2024-40994?

To fix CVE-2024-40994, update to a patched version of the Linux kernel, such as 5.10.223-1 or later.

3

Which versions of the Linux kernel are affected by CVE-2024-40994?

CVE-2024-40994 affects Linux kernel versions from 5.14 to 6.9.7, including various release candidates.

4

What kind of systems are impacted by CVE-2024-40994?

CVE-2024-40994 impacts 32-bit systems due to potential integer overflow during memory allocation.

5

Is CVE-2024-40994 specific to any distributions?

CVE-2024-40994 is relevant across multiple Linux distributions that utilize the affected kernels, particularly Debian.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203