CVE-2024-41002: crypto: hisilicon/sec - Fix memory leak for sec resource release

Published Jul 12, 2024
·
Updated

crypto: hisilicon/sec - Fix memory leak for sec resource release

Affected Software

10 affected componentsFixes available
Linux Linux kernel<5.15.162
Linux Linux kernel>=5.16<6.1.96
Linux Linux kernel>=6.2<6.6.36
Linux Linux kernel>=6.7<6.9.7
Microsoft azl3 kernel 6.6.47.1-1
Microsoft azl3 kernel 6.6.35.1-5
debian/linux<6.1.99-1
6.1.99-1
debian/linux<6.9.7-1
6.9.7-1
debian/linux<6.9.7-1
6.9.7-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.99-1
  2. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.9.7-1
  3. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1
  4. Compensating control

    Update the Hisilicon SEC resource-release path so that AIV resources are released at the same time as the other SEC resources, preventing memory leakage.

Event History

Jul 12, 2024
CVE Published
via MITRE·12:37 PM
Data Sourced
via MITRE·12:37 PM
Description
Data Sourced
via NVD·01:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·01:15 PM
DescriptionSeverityAffected Software
Sep 11, 2024
Data Sourced
via Microsoft·07:00 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-41002?

CVE-2024-41002 has been reported, but the specific severity level is not detailed in the description.

2

How do I fix CVE-2024-41002?

To fix CVE-2024-41002, update the Linux kernel to versions 6.1.123-1, 6.1.119-1, 6.12.11-1, or 6.12.12-1.

3

Which versions of the Linux kernel are affected by CVE-2024-41002?

CVE-2024-41002 affects Linux kernel versions prior to 5.15.162 and those between 5.16 and 6.1.96, as well as various versions up to 6.9.7.

4

What type of vulnerability is CVE-2024-41002?

CVE-2024-41002 is classified as a memory leak vulnerability within the Linux kernel's crypto subsystem.

5

Is there a workaround for CVE-2024-41002?

No specific workaround for CVE-2024-41002 is mentioned; updating the kernel is the recommended action.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203