CVE-2024-41017: jfs: don't walk off the end of ealist

Published Jul 29, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

jfs: don't walk off the end of ealist

Add a check before visiting the members of ea to make sure each ea stays within the ealist.

Affected Software

12 affected componentsFixes available
Linux Linux kernel<4.19.319
Linux Linux kernel>=4.20<5.4.281
Linux Linux kernel>=5.5<5.10.223
Linux Linux kernel>=5.11<5.15.164
Linux Linux kernel>=5.16<6.1.102
Linux Linux kernel>=6.2<6.6.43
Linux Linux kernel>=6.7<6.9.12
Linux Linux kernel>=6.10<6.10.2
debian/linux<6.1.106-1
6.1.106-1
debian/linux<6.9.12-1
6.9.12-1
debian/linux<6.9.12-1
6.9.12-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.106-1
  2. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.9.12-1
  3. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1

Event History

Jul 29, 2024
CVE Published
via MITRE·06:37 AM
Data Sourced
via MITRE·06:37 AM
DescriptionSeverity
Data Sourced
via NVD·07:15 AM
RemedyDescriptionSeverityAffected Software
Data Sourced
via OSV·07:15 AM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-41017?

CVE-2024-41017 has been assessed as a moderate severity vulnerability in the Linux kernel.

2

How do I fix CVE-2024-41017?

To remediate CVE-2024-41017, update your Linux kernel to one of the patched versions such as 5.10.223-1, 5.10.226-1, or 6.1.123-1.

3

What systems are affected by CVE-2024-41017?

CVE-2024-41017 affects specific versions of the Linux kernel, including 5.10.x and 6.1.x series.

4

What type of vulnerability is CVE-2024-41017?

CVE-2024-41017 is a vulnerability that involves improper validation in the jfs module of the Linux kernel.

5

Is there a known exploit for CVE-2024-41017?

As of now, there are no publicly disclosed exploits specifically targeting CVE-2024-41017.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203