CVE-2024-41081: ila: block BH in ila_output()

Published Jul 29, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

ila: block BH in ilaoutput()

As explained in commit 1378817486d6 ("tipc: block BH before using dstcache"), net/core/dstcache.c helpers need to be called with BH disabled.

ilaoutput() is called from lwtunneloutput() possibly from process context, and under rcureadlock().

We might be interrupted by a softirq, re-enter ilaoutput() and corrupt dstcache data structures.

Fix the race by using localbhdisable().

Affected Software

13 affected componentsFixes available
Linux Linux kernel>=4.10<4.19.319
Linux Linux kernel>=4.20<5.4.281
Linux Linux kernel>=5.5<5.10.223
Linux Linux kernel>=5.11<5.15.164
Linux Linux kernel>=5.16<6.1.101
Linux Linux kernel>=6.2<6.6.42
Linux Linux kernel>=6.7<6.9.11
Linux Linux kernel=6.10-rc1
Linux Linux kernel=6.10-rc2
debian/linux<6.1.106-1
6.1.106-1
debian/linux<6.9.11-1
6.9.11-1
debian/linux<6.9.11-1
6.9.11-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.106-1
  2. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.9.11-1
  3. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1

Event History

Jul 29, 2024
CVE Published
via MITRE·03:04 PM
Data Sourced
via MITRE·03:04 PM
DescriptionSeverity
Data Sourced
via NVD·03:15 PM
RemedyDescriptionSeverityAffected Software
Data Sourced
via OSV·03:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-41081?

CVE-2024-41081 is classified as a medium severity vulnerability in the Linux kernel.

2

How do I fix CVE-2024-41081?

To fix CVE-2024-41081, update the Linux kernel to versions 5.10.223-1, 5.10.226-1, 6.1.123-1, 6.1.128-1, or 6.12.12-1.

3

Which Linux versions are affected by CVE-2024-41081?

CVE-2024-41081 affects Linux kernel versions prior to 5.10.223-1, 5.10.226-1, 6.1.123-1, 6.1.128-1, and 6.12.12-1.

4

Is CVE-2024-41081 being actively exploited?

As of the current information, there are no known active exploitations of CVE-2024-41081.

5

What is the impact of CVE-2024-41081?

CVE-2024-41081 may lead to unexpected behavior in the kernel, potentially affecting system stability and security.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203