CVE-2024-41095: drm/nouveau/dispnv04: fix null pointer dereference in nv17_tv_get_ld_modes
drm/nouveau/dispnv04: fix null pointer dereference in nv17tvgetldmodes
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 4.19.317 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 5.4.279 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 5.10.221 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 5.15.162 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 6.1.97 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 6.6.37 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 6.9.8 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 6.10 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.98-1 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.9.8-1 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1 - Compensating control
In nv17_tv_get_ld_modes(), check whether drm_mode_duplicate() returned NULL before dereferencing or using the mode value.
Event History
Frequently Asked Questions
What is the severity of CVE-2024-41095?
CVE-2024-41095 has been rated as a medium-severity vulnerability due to the potential for a NULL pointer dereference leading to system instability.
How do I fix CVE-2024-41095?
To fix CVE-2024-41095, update your Linux kernel to a version that is 4.19.317 or higher, 5.4.279 or higher, or apply the relevant patches provided by your distribution.
Which Linux kernel versions are affected by CVE-2024-41095?
CVE-2024-41095 affects Linux kernel versions prior to 4.19.317, 5.4.279, 5.10.221, 5.15.162, 6.1.97, and 6.6.37.
What systems are impacted by CVE-2024-41095?
CVE-2024-41095 impacts systems running affected versions of the Linux kernel, including various distributions like Red Hat and Debian.
Is there a patch available for CVE-2024-41095?
Yes, patches for CVE-2024-41095 are available as part of the kernel updates for affected Linux distributions.