CVE-2024-42009: RoundCube Webmail Cross-Site Scripting Vulnerability

Published Aug 5, 2024
·
Updated

A Cross-Site Scripting vulnerability in Roundcube through 1.5.7 and 1.6.x through 1.6.7 allows a remote attacker to steal and send emails of a victim via a crafted e-mail message that abuses a Desanitization issue in messagebody() in program/actions/mail/show.php.

Other sources

RoundCube Webmail contains a cross-site scripting vulnerability. This vulnerability could allow a remote attacker to steal and send emails of a victim via a crafted e-mail message that abuses a Desanitization issue in messagebody() in program/actions/mail/show.php.

— CISA

Affected Software

7 affected componentsFixes available
Roundcube Webmail<1.5.8
Roundcube Webmail>=1.6.0<1.6.8
Roundcube Webmail
debian/roundcube<1.6.5+dfsg-1+deb12u3
1.6.5+dfsg-1+deb12u3
debian/roundcube<1.6.8+dfsg-1
1.6.8+dfsg-1
debian/roundcube<1.6.8+dfsg-1
1.6.8+dfsg-1
debian/roundcube
1.6.5+dfsg-1+deb12u91.6.5+dfsg-1+deb12u121.6.18+dfsg-0+deb13u11.6.20+dfsg-0+deb13u11.6.20+dfsg-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/roundcube to a version that resolves this vulnerability.

    Fixed in 1.6.5+dfsg-1+deb12u3
  2. Upgrade

    Upgrade debian/roundcube to a version that resolves this vulnerability.

    Fixed in 1.6.8+dfsg-1
  3. Upgrade

    Upgrade debian/roundcube to a version that resolves this vulnerability.

    Fixed in 1.6.5+dfsg-1+deb12u9Fixed in 1.6.5+dfsg-1+deb12u12Fixed in 1.6.18+dfsg-0+deb13u1Fixed in 1.6.20+dfsg-0+deb13u1Fixed in 1.6.20+dfsg-1

Event History

Aug 5, 2024
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via NVD·07:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·07:15 PM
DescriptionSeverityAffected Software
Feb 11, 2025
Exploit Published
via GitHub·11:02 PM
Jun 9, 2025
Data Sourced
via CISA·12:00 AM
RemedyDescriptionWeaknessAffected Software
Jun 15, 2025
News Published
via The Register·10:01 PM
Jul 8, 2026
News Published
via BleepingComputer·06:56 PM

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2024-42009?

CVE-2024-42009 is considered a critical severity vulnerability due to its potential impact on user data privacy.

2

How do I fix CVE-2024-42009?

To fix CVE-2024-42009, upgrade to Roundcube version 1.5.8 or 1.6.8 and later.

3

What is the nature of the vulnerability CVE-2024-42009?

CVE-2024-42009 is a Cross-Site Scripting vulnerability that allows remote attackers to exploit Desanitization issues.

4

Which versions of Roundcube are affected by CVE-2024-42009?

CVE-2024-42009 affects Roundcube versions prior to 1.5.8 and 1.6.0 through 1.6.7.

5

Can CVE-2024-42009 allow sensitive data theft?

Yes, CVE-2024-42009 can enable attackers to steal sensitive information by executing scripts in a victim's browser.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203