CVE-2024-42102: Revert "mm/writeback: fix possible divide-by-zero in wb_dirty_limits(), again"

Published Jul 30, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

Revert "mm/writeback: fix possible divide-by-zero in wbdirtylimits(), again"

Patch series "mm: Avoid possible overflows in dirty throttling".

Dirty throttling logic assumes dirty limits in page units fit into 32-bits. This patch series makes sure this is true (see patch 2/2 for more details).

This patch (of 2):

This reverts commit 9319b647902cbd5cc884ac08a8a6d54ce111fc78.

The commit is broken in several ways. Firstly, the removed (u64) cast from the multiplication will introduce a multiplication overflow on 32-bit archs if wbthresh bgthresh >= 1<<32 (which is actually common - the default settings with 4GB of RAM will trigger this). Secondly, the div64u64() is unnecessarily expensive on 32-bit archs. We have div64ul() in case we want to be safe & cheap. Thirdly, if dirty thresholds are larger than 1<<32 pages, then dirty balancing is going to blow up in many other spectacular ways anyway so trying to fix one possible overflow is just moot.

Other sources

Revert "mm/writeback: fix possible divide-by-zero in wbdirtylimits() again"

— Microsoft

Affected Software

24 affected componentsFixes available
redhat/kernel<4.19.318
4.19.318
redhat/kernel<5.4.280
5.4.280
redhat/kernel<5.10.222
5.10.222
redhat/kernel<5.15.163
5.15.163
redhat/kernel<6.1.98
6.1.98
redhat/kernel<6.6.39
6.6.39
redhat/kernel<6.9.9
6.9.9
redhat/kernel<6.10
6.10
Linux Linux kernel>=4.19.307<4.19.318
Linux Linux kernel>=5.4.269<5.4.280
Linux Linux kernel>=5.10.210<5.10.222
Linux Linux kernel>=5.15.149<5.15.163
Linux Linux kernel>=6.1.79<6.1.98
Linux Linux kernel>=6.6.18<6.6.39
Linux Linux kernel>=6.8<6.9.9
Microsoft azl3 kernel 6.6.35.1-5
Microsoft cbl2 kernel 5.15.162.2-1
Microsoft cbl2 kernel 5.15.162.2-1
Microsoft azl3 kernel 6.6.47.1-1
Microsoft cbl2 kernel 5.15.164.1-1
debian/linux<6.1.98-1
6.1.98-1
debian/linux<6.9.9-1
6.9.9-1
debian/linux<6.9.9-1
6.9.9-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 4.19.318
  2. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 5.4.280
  3. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 5.10.222
  4. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 5.15.163
  5. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.1.98
  6. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.6.39
  7. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.9.9
  8. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 6.10
  9. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.98-1
  10. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.9.9-1
  11. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1
  12. Upgrade

    Upgrade Linux kernel to a version that resolves this vulnerability.

    Patch 9319b647902cbd5cc884ac08a8a6d54ce111fc78

Event History

Jul 30, 2024
CVE Published
via MITRE·07:45 AM
Data Sourced
via MITRE·07:45 AM
Description
Data Sourced
via NVD·08:15 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·08:15 AM
DescriptionSeverityAffected Software
Sep 11, 2024
Data Sourced
via Microsoft·07:00 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-42102?

CVE-2024-42102 has been classified as a moderate-severity vulnerability in the Linux kernel.

2

How do I fix CVE-2024-42102?

To fix CVE-2024-42102, update the Linux kernel to version 4.19.318, 5.4.280, 5.10.222, 5.15.163, 6.1.98, 6.6.39, 6.9.9, or 6.10 as appropriate.

3

What versions of the Linux kernel are affected by CVE-2024-42102?

CVE-2024-42102 affects versions of the Linux kernel prior to 4.19.318, 5.4.280, 5.10.222, 5.15.163, 6.1.98, 6.6.39, 6.9.9, and 6.10.

4

Is there a workaround for CVE-2024-42102?

There are no known workarounds for CVE-2024-42102; the recommended action is to apply the security updates.

5

Which distributions are impacted by CVE-2024-42102?

CVE-2024-42102 impacts distributions using the affected versions of the Linux kernel such as Red Hat and Debian.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203