CVE-2024-42157: s390/pkey: Wipe sensitive data on failure

Published Jul 30, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

s390/pkey: Wipe sensitive data on failure

Wipe sensitive data from stack also if the copytouser() fails.

Affected Software

16 affected componentsFixes available
Linux Linux kernel>=4.11<4.19.318
Linux Linux kernel>=4.20<5.4.280
Linux Linux kernel>=5.5<5.10.222
Linux Linux kernel>=5.11<5.15.163
Linux Linux kernel>=5.16<6.1.98
Linux Linux kernel>=6.2<6.6.39
Linux Linux kernel>=6.7<6.9.9
Microsoft cbl2 kernel 5.15.162.2-1
Microsoft cbl2 kernel 5.15.164.1-1
Microsoft azl3 kernel 6.6.35.1-5
Microsoft cbl2 kernel 5.15.162.2-1
Microsoft azl3 kernel 6.6.43.1-7
debian/linux<6.1.98-1
6.1.98-1
debian/linux<6.9.9-1
6.9.9-1
debian/linux<6.9.9-1
6.9.9-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.98-1
  2. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.9.9-1
  3. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1
  4. Compensating control

    Wipe sensitive data from the stack when copy_to_user() fails in the s390/pkey code path.

Event History

Jul 30, 2024
CVE Published
via MITRE·07:46 AM
Data Sourced
via MITRE·07:46 AM
Description
Data Sourced
via NVD·08:15 AM
RemedyDescriptionSeverityAffected Software
Data Sourced
via OSV·08:15 AM
DescriptionSeverityAffected Software
Aug 16, 2024
Data Sourced
via Microsoft·07:00 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-42157?

CVE-2024-42157 has been rated as a moderate severity vulnerability in the Linux kernel.

2

How do I fix CVE-2024-42157?

To address CVE-2024-42157, update your Linux kernel to the fixed versions listed in the official advisories.

3

Which versions of the Linux kernel are affected by CVE-2024-42157?

CVE-2024-42157 affects several Linux kernel versions prior to the patched releases including those listed in the vulnerability report.

4

What component of the Linux kernel is impacted by CVE-2024-42157?

CVE-2024-42157 impacts the s390/pkey component of the Linux kernel.

5

Is CVE-2024-42157 a local or remote vulnerability?

CVE-2024-42157 is considered a local vulnerability as it requires local access to the system to exploit.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203