CVE-2024-42281: bpf: Fix a segment issue when downgrading gso_size

Published Aug 17, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

bpf: Fix a segment issue when downgrading gsosize

Linearize the skb when downgrading gsosize because it may trigger a BUGON() later when the skb is segmented as described in [1,2].

Affected Software

10 affected componentsFixes available
Linux Linux kernel>=4.13<5.4.282
Linux Linux kernel>=5.5<5.10.224
Linux Linux kernel>=5.11<5.15.165
Linux Linux kernel>=5.16<6.1.103
Linux Linux kernel>=6.2<6.6.44
Linux Linux kernel>=6.7<6.10.3
debian/linux<6.1.106-1
6.1.106-1
debian/linux<6.10.3-1
6.10.3-1
debian/linux<6.10.3-1
6.10.3-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1
  2. Upgrade

    Upgrade debian/linux-6.1 to a version that resolves this vulnerability.

    Fixed in 6.1.129-1~deb11u1
  3. Compensating control

    Linearize the skb when downgrading gso_size to prevent a later BUG_ON() during skb segmentation.

Event History

Aug 17, 2024
CVE Published
via MITRE·09:08 AM
Data Sourced
via MITRE·09:08 AM
Description
Data Sourced
via NVD·09:15 AM
RemedyDescriptionSeverityAffected Software
Data Sourced
via OSV·09:15 AM
DescriptionSeverityAffected Software

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-42281?

The severity of CVE-2024-42281 has not been explicitly rated, but it addresses a bug that could lead to segmentation issues in the Linux kernel.

2

How do I fix CVE-2024-42281?

To fix CVE-2024-42281, update to Linux kernel versions 5.10.226-1, 6.1.123-1, 6.1.119-1, 6.12.10-1, or 6.12.11-1 for Debian systems.

3

Which Linux kernel versions are affected by CVE-2024-42281?

Linux kernel versions up to and including 5.10.223-1 and the specific 6.1 version without the mentioned patch are affected by CVE-2024-42281.

4

What was the cause of CVE-2024-42281?

CVE-2024-42281 was caused by a segment issue when downgrading gso_size, which could lead to further segmentation problems in the kernel.

5

Is CVE-2024-42281 specific to any Linux distribution?

CVE-2024-42281 specifically affects Debian Linux distributions, and remedial updates are available for its kernel packages.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203