CVE-2024-42312: sysctl: always initialize i_uid/i_gid

Published Aug 17, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

sysctl: always initialize iuid/igid

Always initialize iuid/igid inside the sysfs core so setownership() can safely skip setting them.

Commit 5ec27ec735ba ("fs/proc/procsysctl.c: fix the default values of iuid/igid on /proc/sys inodes.") added defaults for iuid/igid when setownership() was not implemented. It also missed adjusting netctlsetownership() to use the same default values in case the computation of a better value failed.

Affected Software

13 affected componentsFixes available
Linux Linux kernel>=4.9.187<4.10
Linux Linux kernel>=4.14.135<4.15
Linux Linux kernel>=4.19.61<4.20
Linux Linux kernel>=5.1.20<5.2
Linux Linux kernel>=5.2.3<5.10.224
Linux Linux kernel>=5.11<5.15.165
Linux Linux kernel>=5.16<6.1.104
Linux Linux kernel>=6.2<6.6.45
Linux Linux kernel>=6.7<6.10.3
debian/linux<6.1.106-1
6.1.106-1
debian/linux<6.10.3-1
6.10.3-1
debian/linux<6.10.3-1
6.10.3-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1
  2. Upgrade

    Upgrade debian/linux-6.1 to a version that resolves this vulnerability.

    Fixed in 6.1.129-1~deb11u1

Event History

Aug 17, 2024
CVE Published
via MITRE·09:09 AM
Data Sourced
via MITRE·09:09 AM
Description
Data Sourced
via NVD·09:15 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·09:15 AM
DescriptionSeverityAffected Software

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-42312?

CVE-2024-42312 has been assigned a medium severity rating due to its impact on system ownership attributes.

2

How do I fix CVE-2024-42312?

To fix CVE-2024-42312, upgrade the Linux kernel to versions 5.10.226-1, 6.1.123-1, 6.1.119-1, 6.12.10-1, or 6.12.11-1.

3

What systems are affected by CVE-2024-42312?

CVE-2024-42312 affects specific versions of the Linux kernel in Debian distributions.

4

What can happen if CVE-2024-42312 is exploited?

Exploitation of CVE-2024-42312 may lead to improper ownership being set, affecting system security.

5

When was CVE-2024-42312 resolved?

CVE-2024-42312 was resolved with the commit made on the Linux kernel, which focused on initializing ownership attributes.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203