CVE-2024-42322: ipvs: properly dereference pe in ip_vs_add_service

Published Aug 17, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

ipvs: properly dereference pe in ipvsaddservice

Use pe directly to resolve sparse warning:

net/netfilter/ipvs/ipvsctl.c:1471:27: warning: dereference of noderef expression

Affected Software

9 affected componentsFixes available
Linux Linux kernel>=4.7<5.10.237
Linux Linux kernel>=5.11<5.15.181
Linux Linux kernel>=5.16<6.1.119
Linux Linux kernel>=6.2<6.6.44
Linux Linux kernel>=6.7<6.10.3
debian/linux<6.1.119-1
6.1.119-1
debian/linux<6.10.3-1
6.10.3-1
debian/linux<6.10.3-1
6.10.3-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1
  2. Upgrade

    Upgrade debian/linux-6.1 to a version that resolves this vulnerability.

    Fixed in 6.1.129-1~deb11u1

Event History

Aug 17, 2024
CVE Published
via MITRE·09:09 AM
Data Sourced
via MITRE·09:09 AM
Description
Data Sourced
via NVD·09:15 AM
RemedyDescriptionSeverityAffected Software
Data Sourced
via OSV·09:15 AM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-42322?

CVE-2024-42322 has been classified with a moderate severity due to the potential impact on the Linux kernel's IP Virtual Server (IPVS) functionality.

2

How do I fix CVE-2024-42322?

To fix CVE-2024-42322, update your Linux kernel to the recommended versions such as 6.1.123-1 or 6.1.119-1 for Debian.

3

What is affected by CVE-2024-42322?

CVE-2024-42322 affects specific versions of the Linux kernel, particularly versions up to 5.10.226-1.

4

Is there a workaround for CVE-2024-42322?

Currently, no specific workaround is provided for CVE-2024-42322; updating the kernel is the suggested course of action.

5

Who is affected by CVE-2024-42322?

Anyone using the affected versions of the Linux kernel in their systems may be vulnerable to CVE-2024-42322.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203