CVE-2024-43425: Moodle Remote Code Execution vulnerability
A flaw was found in Moodle. Additional restrictions are required to avoid a remote code execution risk in calculated question types. Note: This requires the capability to add/update questions.
Other sources
Moodle Remote Code Execution vulnerability
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.4.2 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.3.6 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.2.9 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.1.12
Event History
Frequently Asked Questions
What is the severity of CVE-2024-43425?
CVE-2024-43425 is rated as a high severity vulnerability due to its potential for remote code execution in specific conditions.
How do I fix CVE-2024-43425?
To resolve CVE-2024-43425, upgrade to Moodle versions 4.4.2, 4.3.6, 4.2.9, or 4.1.12 or later.
What versions of Moodle are affected by CVE-2024-43425?
CVE-2024-43425 affects Moodle versions prior to 4.4.2, 4.3.6, 4.2.9, and 4.1.12.
Can CVE-2024-43425 lead to data compromise?
Yes, CVE-2024-43425 poses a risk of remote code execution which could potentially lead to data compromise.
What type of vulnerability is CVE-2024-43425?
CVE-2024-43425 is a remote code execution vulnerability specifically related to calculated question types in Moodle.