CVE-2024-43426: Moodle has arbitrary file read risk through pdfTeX

Published Nov 7, 2024
·
Updated

A flaw was found in pdfTeX. Insufficient sanitizing in the TeX notation filter resulted in an arbitrary file read risk on sites where pdfTeX is available, such as those with TeX Live installed.

Other sources

Moodle has arbitrary file read risk through pdfTeX

— Packagist

Affected Software

12 affected componentsFixes available
composer/moodle/moodle>=4.4.0-beta<4.4.2
4.4.2
composer/moodle/moodle>=4.3.0-beta<4.3.6
4.3.6
composer/moodle/moodle>=4.2.0-beta<4.2.9
4.2.9
composer/moodle/moodle<4.1.12
4.1.12
Moodle Moodle>=4.1.0<4.1.12
Moodle Moodle>=4.2.0<4.2.9
Moodle Moodle>=4.3.0<4.3.6
Moodle Moodle>=4.4.0<4.4.2
composer/moodle/moodle>=4.4.0-beta, <4.4.2
4.4.2
composer/moodle/moodle>=4.3.0-beta, <4.3.6
4.3.6
composer/moodle/moodle>=4.2.0-beta, <4.2.9
4.2.9
composer/moodle/moodle<4.1.12
4.1.12

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.4.2
  2. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.3.6
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.2.9
  4. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.1.12

Event History

Nov 7, 2024
CVE Published
via MITRE·01:22 PM
Data Sourced
via MITRE·01:22 PM
DescriptionSeverity
Data Sourced
via NVD·02:15 PM
DescriptionSeverityWeaknessAffected Software
Advisory Published
via GitHub·03:31 PM
Data Sourced
via GitHub·03:31 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·03:31 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2024-43426?

CVE-2024-43426 has been classified as a moderate severity vulnerability due to the risk of arbitrary file reading.

2

How do I fix CVE-2024-43426?

To fix CVE-2024-43426, upgrade to the latest recommended version of Moodle which includes the resolution for this vulnerability.

3

What versions of Moodle are affected by CVE-2024-43426?

Versions of Moodle from 4.1.0 to 4.4.1 are affected by CVE-2024-43426.

4

What is the nature of the vulnerability in CVE-2024-43426?

CVE-2024-43426 involves insufficient sanitizing in the TeX notation filter, leading to an arbitrary file read risk.

5

Is there a workaround for CVE-2024-43426 until I can apply the patch?

Currently, the recommended action is to update Moodle to a secure version as there are no known effective workarounds for CVE-2024-43426.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203