CVE-2024-43431: Moodle's IDOR in badges allows deletion of arbitrary badges

Published Nov 7, 2024
·
Updated

A vulnerability was found in Moodle. Insufficient capability checks made it possible to delete badges that a user does not have permission to access.

Other sources

Moodle's IDOR in badges allows deletion of arbitrary badges

— Packagist

Affected Software

12 affected componentsFixes available
composer/moodle/moodle>=4.4.0-beta<4.4.2
4.4.2
composer/moodle/moodle>=4.3.0-beta<4.3.6
4.3.6
composer/moodle/moodle>=4.2.0-beta<4.2.9
4.2.9
composer/moodle/moodle<4.1.12
4.1.12
Moodle Moodle<4.1.12
Moodle Moodle>=4.2.0<4.2.9
Moodle Moodle>=4.3.0<4.3.6
Moodle Moodle>=4.4.0<4.4.2
composer/moodle/moodle>=4.4.0-beta, <4.4.2
4.4.2
composer/moodle/moodle>=4.3.0-beta, <4.3.6
4.3.6
composer/moodle/moodle>=4.2.0-beta, <4.2.9
4.2.9
composer/moodle/moodle<4.1.12
4.1.12

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.4.2
  2. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.3.6
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.2.9
  4. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.1.12

Event History

Nov 7, 2024
CVE Published
via MITRE·01:27 PM
Data Sourced
via MITRE·01:27 PM
DescriptionSeverity
Data Sourced
via NVD·02:15 PM
DescriptionSeverityWeaknessAffected Software
Advisory Published
via GitHub·03:31 PM
Data Sourced
via GitHub·03:31 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·03:31 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2024-43431?

CVE-2024-43431 has been rated as a moderate severity vulnerability due to insufficient capability checks.

2

How do I fix CVE-2024-43431?

To fix CVE-2024-43431, you should update to Moodle versions 4.4.2, 4.3.6, 4.2.9, or 4.1.12.

3

What systems are impacted by CVE-2024-43431?

CVE-2024-43431 affects Moodle versions prior to 4.4.2, 4.3.6, 4.2.9, and 4.1.12.

4

What type of vulnerability is CVE-2024-43431?

CVE-2024-43431 is a privilege escalation vulnerability allowing users to delete badges without permission.

5

Who is affected by CVE-2024-43431?

Users of Moodle who have access to badge management features may be affected by CVE-2024-43431.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203