CVE-2024-43436: Moodle vulnerable to site administration SQL injection via XMLDB editor
A SQL injection risk flaw was found in the XMLDB editor tool available to site administrators.
Other sources
Moodle vulnerable to site administration SQL injection via XMLDB editor
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.4.2 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.3.6 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.2.9 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 4.1.12
Event History
Frequently Asked Questions
What is the severity of CVE-2024-43436?
CVE-2024-43436 is classified as a critical SQL injection vulnerability that poses significant risks to affected systems.
How do I fix CVE-2024-43436?
To fix CVE-2024-43436, you should update Moodle to versions 4.4.2, 4.3.6, 4.2.9, or 4.1.12 as appropriate.
Who is affected by CVE-2024-43436?
CVE-2024-43436 affects Moodle versions from 4.1.12 up to but not including 4.4.2.
What components are vulnerable in CVE-2024-43436?
The vulnerability is found in the XMLDB editor tool utilized by site administrators in Moodle.
Is CVE-2024-43436 exploitable remotely?
Yes, CVE-2024-43436 is considered exploitable remotely, allowing attackers to execute SQL injection attacks.