CVE-2024-43439: Moodle reflected XSS via H5P error message

Published Nov 11, 2024
·
Updated

A flaw was found in moodle. H5P error messages require additional sanitizing to prevent a reflected cross-site scripting (XSS) risk.

Other sources

Moodle reflected XSS via H5P error message

— Packagist

Affected Software

13 affected componentsFixes available
Moodle Moodle
composer/moodle/moodle>=4.4.0-beta<4.4.2
4.4.2
composer/moodle/moodle>=4.3.0-beta<4.3.6
4.3.6
composer/moodle/moodle>=4.2.0-beta<4.2.9
4.2.9
composer/moodle/moodle<4.1.12
4.1.12
Moodle Moodle<4.1.12
Moodle Moodle>=4.2.0<4.2.9
Moodle Moodle>=4.3.0<4.3.6
Moodle Moodle>=4.4.0<4.4.2
composer/moodle/moodle>=4.4.0-beta, <4.4.2
4.4.2
composer/moodle/moodle>=4.3.0-beta, <4.3.6
4.3.6
composer/moodle/moodle>=4.2.0-beta, <4.2.9
4.2.9
composer/moodle/moodle<4.1.12
4.1.12

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.4.2
  2. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.3.6
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.2.9
  4. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 4.1.12

Event History

Nov 11, 2024
CVE Published
via MITRE·04:00 PM
Data Sourced
via MITRE·04:00 PM
DescriptionSeverity
Data Sourced
via NVD·04:15 PM
DescriptionSeverityWeaknessAffected Software
Advisory Published
via GitHub·06:30 PM
Data Sourced
via GitHub·06:30 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·06:30 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2024-43439?

CVE-2024-43439 has been classified as a moderate severity vulnerability due to its potential for reflected cross-site scripting (XSS) attacks.

2

How do I fix CVE-2024-43439?

To fix CVE-2024-43439, update your Moodle installation to the latest version that contains the necessary sanitization improvements.

3

Who is affected by CVE-2024-43439?

CVE-2024-43439 affects users of Moodle who utilize H5P functionalities without the appropriate security patches.

4

What is the nature of the vulnerability in CVE-2024-43439?

CVE-2024-43439 is a reflected cross-site scripting (XSS) vulnerability that requires additional sanitization of error messages within the H5P functionality.

5

Is CVE-2024-43439 being actively exploited?

As of now, there have been no reported instances of CVE-2024-43439 being actively exploited in the wild, but it poses a risk to affected systems.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203