CVE-2024-43767: Input Validation

Published Dec 1, 2024
·
Updated

In preparetodrawintomask of SkBlurMaskFilterImpl.cpp, there is a possible heap overflow due to improper input validation. This could lead to remote code execution with no additional execution privileges needed. User interaction is not needed for exploitation.

Affected Software

13 affected componentsFixes available
Google Android=12.0
Google Android=12.1
Google Android=13.0
Google Android=14.0
Google Android=15.0
Google Android
android/platform/external/skia>=12:0<12:2024-12-01
12:2024-12-01
android/platform/external/skia>=12L:0<12L:2024-12-01
12L:2024-12-01
android/platform/external/skia>=13:0<13:2024-12-01
13:2024-12-01
android/platform/external/skia>=14:0<14:2024-12-01
14:2024-12-01
debian/libskia
146.20260602~git.3476902+dfsg-5
debian/webkit2gtk<=2.50.6-1~deb12u2, <=2.50.6-1~deb12u1, <=2.52.6-1~deb13u1, <=2.52.6-1
2.54.0-1~deb13u32.54.2-2
debian/wpewebkit<=2.38.6-1, <=2.48.3-1
2.54.2-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade android/platform/external/skia to a version that resolves this vulnerability.

    Fixed in 12:2024-12-01
  2. Upgrade

    Upgrade android/platform/external/skia to a version that resolves this vulnerability.

    Fixed in 12L:2024-12-01
  3. Upgrade

    Upgrade android/platform/external/skia to a version that resolves this vulnerability.

    Fixed in 13:2024-12-01
  4. Upgrade

    Upgrade android/platform/external/skia to a version that resolves this vulnerability.

    Fixed in 14:2024-12-01
  5. Upgrade

    Upgrade debian/libskia to a version that resolves this vulnerability.

    Fixed in 146.20260602~git.3476902+dfsg-5
  6. Upgrade

    Upgrade debian/webkit2gtk to a version that resolves this vulnerability.

    Fixed in 2.54.0-1~deb13u3Fixed in 2.54.2-2
  7. Upgrade

    Upgrade debian/wpewebkit to a version that resolves this vulnerability.

    Fixed in 2.54.2-1

Event History

Dec 1, 2024
Advisory Published
via OSV·12:00 AM
Data Sourced
via OSV·12:00 AM
DescriptionAffected Software
Dec 2, 2024
CVE Published
via Android·12:00 AM
Data Sourced
via Android·12:00 AM
SeverityWeaknessAffected Software
Jan 2, 2025
CVE Published
via MITRE·11:58 PM
Data Sourced
via MITRE·11:58 PM
DescriptionWeakness

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2024-43767?

The severity of CVE-2024-43767 is critical due to the potential for remote code execution.

2

How do I fix CVE-2024-43767?

To fix CVE-2024-43767, users should update to the latest version of affected Android software provided by Google.

3

What causes CVE-2024-43767?

CVE-2024-43767 is caused by improper input validation leading to a possible heap overflow.

4

Who is affected by CVE-2024-43767?

CVE-2024-43767 affects users of the Android operating system.

5

Can CVE-2024-43767 be exploited without user interaction?

Yes, CVE-2024-43767 can be exploited without any user interaction needed.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203