CVE-2024-43805: HTML injection in Jupyter Notebook and JupyterLab leading to DOM Clobbering

Published Aug 28, 2024
·
Updated

Impact

The vulnerability depends on user interaction by opening a malicious notebook with Markdown cells, or Markdown file using JupyterLab preview feature.

A malicious user can access any data that the attacked user has access to as well as perform arbitrary requests acting as the attacked user.

Patches

JupyterLab v3.6.8, v4.2.5 and Jupyter Notebook v7.2.2 were patched.

Workarounds

There is no workaround for the underlying DOM Clobbering susceptibility. However, select plugins can be disabled on deployments which cannot update in a timely fashion to minimise the risk. These are: - @jupyterlab/mathjax-extension:plugin - users will loose ability to preview mathematical equations - @jupyterlab/markdownviewer-extension:plugin - users will loose ability to open Markdown previews - @jupyterlab/mathjax2-extension:plugin (if installed with optional jupyterlab-mathjax2 package) - an older version of the mathjax plugin for JupyterLab 4.x

To disable these extensions run:

bash jupyter labextension disable @jupyterlab/markdownviewer-extension:plugin jupyter labextension disable @jupyterlab/mathjax-extension:plugin jupyter labextension disable @jupyterlab/mathjax2-extension:plugin

To confirm that the plugins were disabled run:

bash jupyter labextension list

References

None

Notes

This change has a potential to break rendering of some markdown. There is a setting in Sanitizer which allows to revert to the previous sanitizer settings (allowNamedProperties).

Other sources

jupyterlab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. This vulnerability depends on user interaction by opening a malicious notebook with Markdown cells, or Markdown file using JupyterLab preview feature. A malicious user can access any data that the attacked user has access to as well as perform arbitrary requests acting as the attacked user. JupyterLab v3.6.8, v4.2.5 and Jupyter Notebook v7.2.2 have been patched to resolve this issue. Users are advised to upgrade. There is no workaround for the underlying DOM Clobbering susceptibility. However, select plugins can be disabled on deployments which cannot update in a timely fashion to minimise the risk. These are: 1. @jupyterlab/mathjax-extension:plugin - users will loose ability to preview mathematical equations. 2. @jupyterlab/markdownviewer-extension:plugin - users will loose ability to open Markdown previews. 3. @jupyterlab/mathjax2-extension:plugin (if installed with optional jupyterlab-mathjax2 package) - an older version of the mathjax plugin for JupyterLab 4.x. To disable these extensions run: jupyter labextension disable @jupyterlab/markdownviewer-extension:plugin && jupyter labextension disable @jupyterlab/mathjax-extension:plugin && jupyter labextension disable @jupyterlab/mathjax2-extension:plugin in bash.

— MITRE

Affected Software

10 affected componentsFixes available
pip/jupyterlab>=4.0.0<=4.2.4
4.2.5
pip/notebook>=7.0.0<=7.2.1
7.2.2
pip/jupyterlab<=3.6.7
3.6.8
jupyter JupyterLab<3.6.8
jupyter JupyterLab>=4.0.0<4.2.5
jupyter notebook>=7.0.0<7.2.2
debian/jupyterlab<4.0.11+ds1+~cs11.25.27-3
4.0.11+ds1+~cs11.25.27-3
debian/jupyterlab<4.0.11+ds1+~cs11.25.27-3
4.0.11+ds1+~cs11.25.27-3
debian/jupyter-notebook
6.4.12-2.26.4.13-57.4.7-3
debian/jupyterlab
4.0.11+ds1+~cs11.25.27-74.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-6

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade pip/jupyterlab to a version that resolves this vulnerability.

    Fixed in 4.2.5
  2. Upgrade

    Upgrade pip/notebook to a version that resolves this vulnerability.

    Fixed in 7.2.2
  3. Upgrade

    Upgrade pip/jupyterlab to a version that resolves this vulnerability.

    Fixed in 3.6.8
  4. Upgrade

    Upgrade debian/jupyterlab to a version that resolves this vulnerability.

    Fixed in 4.0.11+ds1+~cs11.25.27-3
  5. Upgrade

    Upgrade debian/jupyter-notebook to a version that resolves this vulnerability.

    Fixed in 6.4.12-2.2Fixed in 6.4.13-5Fixed in 7.4.7-3
  6. Upgrade

    Upgrade debian/jupyterlab to a version that resolves this vulnerability.

    Fixed in 4.0.11+ds1+~cs11.25.27-7Fixed in 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-6
  7. Upgrade

    Upgrade JupyterLab to a version that resolves this vulnerability.

    Fixed in 3.6.8
  8. Upgrade

    Upgrade JupyterLab to a version that resolves this vulnerability.

    Fixed in 4.2.5
  9. Upgrade

    Upgrade Jupyter Notebook to a version that resolves this vulnerability.

    Fixed in 7.2.2
  10. Configuration

    Disable @jupyterlab/markdownviewer-extension:plugin, @jupyterlab/mathjax-extension:plugin, and @jupyterlab/mathjax2-extension:plugin with jupyter labextension disable.

    JupyterLab extensions enabled extensions = disabled
  11. Configuration

    Use the Sanitizer allowNamedProperties setting to revert to the previous sanitizer settings; this may break rendering of some Markdown.

    Sanitizer allowNamedProperties

Event History

Aug 28, 2024
CVE Published
via MITRE·07:43 PM
Data Sourced
via MITRE·07:43 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·08:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·08:15 PM
Affected Software
Aug 29, 2024
Advisory Published
via GitHub·05:55 PM

Frequently Asked Questions

1

What is the severity of CVE-2024-43805?

The severity of CVE-2024-43805 is critical due to its potential for unauthorized data access and arbitrary requests.

2

How do I fix CVE-2024-43805?

To fix CVE-2024-43805, upgrade JupyterLab to version 4.2.5 or later, or Notebook to version 7.2.2 or later.

3

Which versions of JupyterLab are affected by CVE-2024-43805?

CVE-2024-43805 affects JupyterLab versions from 4.0.0 to 4.2.4 and 3.6.7 and below.

4

Which versions of Notebook are affected by CVE-2024-43805?

CVE-2024-43805 affects Notebook versions from 7.0.0 to 7.2.1.

5

What types of attacks can CVE-2024-43805 enable?

CVE-2024-43805 can enable attackers to access user data and perform actions on behalf of the user through malicious Markdown cells.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203