CVE-2024-43831: media: mediatek: vcodec: Handle invalid decoder vsi
In the Linux kernel, the following vulnerability has been resolved:
media: mediatek: vcodec: Handle invalid decoder vsi
Handle an invalid decoder vsi in vpudecinit to ensure the decoder vsi is valid for future use.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1
Event History
Frequently Asked Questions
What is the severity of CVE-2024-43831?
CVE-2024-43831 is classified as a moderate severity vulnerability.
How do I fix CVE-2024-43831?
To fix CVE-2024-43831, update your Linux kernel packages to versions 6.12.11-1 or 6.12.12-1 or later.
Which Linux kernel versions are affected by CVE-2024-43831?
CVE-2024-43831 affects several Linux kernel versions, including up to 5.10.226-1 and 6.1.123-1.
What issue does CVE-2024-43831 address?
CVE-2024-43831 addresses a vulnerability related to handling an invalid decoder vsi in the MediaTek video codec.
Is there an exploit available for CVE-2024-43831?
As of now, there is no publicly disclosed exploit for CVE-2024-43831.