CVE-2024-43835: virtio_net: Fix napi_skb_cache_put warning
In the Linux kernel, the following vulnerability has been resolved:
virtionet: Fix napiskbcacheput warning
After the commit bdacf3e34945 ("net: Use nested-BH locking for napialloccache.") was merged, the following warning began to appear:
WARNING: CPU: 5 PID: 1 at net/core/skbuff.c:1451 napiskbcacheput+0x82/0x4b0
warn+0x12f/0x340 napiskbcacheput+0x82/0x4b0 napiskbcacheput+0x82/0x4b0 reportbug+0x165/0x370 handlebug+0x3d/0x80 excinvalidop+0x1a/0x50 asmexcinvalidop+0x1a/0x20 freeoldxmit+0x1c8/0x510 napiskbcacheput+0x82/0x4b0 freeoldxmit+0x1c8/0x510 freeoldxmit+0x1c8/0x510 pfxfreeoldxmit+0x10/0x10
The issue arises because virtio is assuming it's running in NAPI context even when it's not, such as in the netpoll case.
To resolve this, modify virtnetpolltx() to only set NAPI when budget is available. Same for virtnetpollcleantx(), which always assumed that it was in a NAPI context.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1 - Upgrade
Upgrade
debian/linux-6.1to a version that resolves this vulnerability.Fixed in 6.1.129-1~deb11u1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 5.15.176.3-1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 6.6.64.2-9
Event History
Frequently Asked Questions
What is the severity of CVE-2024-43835?
CVE-2024-43835 is classified as a high severity vulnerability affecting the Linux kernel.
How do I fix CVE-2024-43835?
To fix CVE-2024-43835, upgrade to the recommended versions of the Linux kernel, specifically those equal to or higher than 5.10.226-1, 6.1.123-1, or 6.12.12-1.
Which versions of the Linux kernel are affected by CVE-2024-43835?
CVE-2024-43835 affects all Linux kernel versions from 5.0 up to 6.10.3 inclusive.
What type of vulnerability is CVE-2024-43835?
CVE-2024-43835 is a warning issue related to the virtio_net component in the Linux kernel.
Is there a workaround for CVE-2024-43835?
There is no known workaround for CVE-2024-43835, and the recommended action is to update the kernel.