CVE-2024-43837: bpf: Fix null pointer dereference in resolve_prog_type() for BPF_PROG_TYPE_EXT

Published Aug 17, 2024
·
Updated

bpf: Fix null pointer dereference in resolveprogtype() for BPFPROGTYPEEXT

Affected Software

9 affected componentsFixes available
Linux Linux kernel>=5.18<6.1.103
Linux Linux kernel>=6.2<6.6.44
Linux Linux kernel>=6.7<6.10.3
Microsoft azl3 kernel 6.6.43.1-7
Microsoft azl3 kernel 6.6.47.1-1
debian/linux<6.1.106-1
6.1.106-1
debian/linux<6.10.3-1
6.10.3-1
debian/linux<6.10.3-1
6.10.3-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.106-1
  2. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.10.3-1
  3. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1
  4. Compensating control

    Update resolve_prog_type() to return prog->type for BPF_PROG_TYPE_EXT when prog->aux->dst_prog is null or not present, preventing the null pointer dereference.

Event History

Aug 17, 2024
CVE Published
via MITRE·09:21 AM
Data Sourced
via MITRE·09:21 AM
Description
Data Sourced
via NVD·10:15 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·10:15 AM
DescriptionSeverityAffected Software
Sep 11, 2024
Data Sourced
via Microsoft·07:00 AM
DescriptionSeverityWeaknessAffected Software

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-43837?

The severity of CVE-2024-43837 has not been explicitly stated, but it involves a null pointer dereference which can lead to potential crashes in the kernel.

2

How do I fix CVE-2024-43837?

To fix CVE-2024-43837, upgrade to the recommended kernel versions that address this vulnerability, such as linux 5.10.223-1, 5.10.226-1, or 6.12.12-1.

3

What versions of the Linux kernel are affected by CVE-2024-43837?

CVE-2024-43837 affects multiple versions of the Linux kernel ranging from 5.18 to 6.6.44, including specific builds within those ranges.

4

Is CVE-2024-43837 a critical vulnerability?

While CVE-2024-43837 is not classified as critical, it poses risks due to potential crashes from null pointer dereference in the kernel.

5

What should I do if I can't immediately upgrade to address CVE-2024-43837?

If you cannot upgrade immediately, ensure that your system is monitored closely for unusual behavior and be prepared to patch as soon as possible.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203