CVE-2024-43858: jfs: Fix array-index-out-of-bounds in diFree

Published Aug 17, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

jfs: Fix array-index-out-of-bounds in diFree

Other sources

This CVE was automatically created from a reference found in an email or other text. If you are reading this, then this CVE entry is probably erroneous, since this text should be replaced by the official CVE description automatically.

— Launchpad

Affected Software

16 affected componentsFixes available
Linux Linux kernel>=2.6.12<4.19.320
Linux Linux kernel>=4.20<5.4.282
Linux Linux kernel>=5.5<5.10.224
Linux Linux kernel>=5.11<5.15.165
Linux Linux kernel>=5.16<6.1.103
Linux Linux kernel>=6.2<6.6.44
Linux Linux kernel>=6.7<6.10.3
Microsoft azl3 kernel 6.6.43.1-7
Microsoft cbl2 kernel 5.15.164.1-1
Microsoft cbl2 kernel 5.15.167.1-1
Microsoft cbl2 kernel 5.15.164.1-1
Microsoft azl3 kernel 6.6.47.1-1
debian/linux<6.1.106-1
6.1.106-1
debian/linux<6.10.3-1
6.10.3-1
debian/linux<6.10.3-1
6.10.3-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1
  2. Upgrade

    Upgrade debian/linux-6.1 to a version that resolves this vulnerability.

    Fixed in 6.1.129-1~deb11u1

Event History

Aug 17, 2024
CVE Published
via MITRE·09:24 AM
Data Sourced
via MITRE·09:24 AM
DescriptionSeverity
Data Sourced
via NVD·10:15 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·10:15 AM
DescriptionSeverityAffected Software
Sep 11, 2024
Data Sourced
via Microsoft·07:00 AM
DescriptionSeverityWeaknessAffected Software

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-43858?

CVE-2024-43858 is considered a medium severity vulnerability due to its potential impact on system stability.

2

How do I fix CVE-2024-43858?

To fix CVE-2024-43858, update your Linux kernel to version 5.10.226-1 or later, or apply any relevant patches provided by your distribution.

3

What systems are affected by CVE-2024-43858?

CVE-2024-43858 affects various versions of the Linux kernel, specifically those prior to 5.10.226-1.

4

What type of vulnerability is CVE-2024-43858?

CVE-2024-43858 is an array-index-out-of-bounds vulnerability in the jfs filesystem of the Linux kernel.

5

Is there a known exploit for CVE-2024-43858?

As of now, there is no public knowledge of active exploits specifically targeting CVE-2024-43858.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203