CVE-2024-43875: PCI: endpoint: Clean up error handling in vpci_scan_bus()

Published Aug 21, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

PCI: endpoint: Clean up error handling in vpciscanbus()

Smatch complains about inconsistent NULL checking in vpciscanbus():

drivers/pci/endpoint/functions/pci-epf-vntb.c:1024 vpciscanbus() error: we previously assumed 'vpcibus' could be null (see line 1021)

Instead of printing an error message and then crashing we should return an error code and clean up.

Also the NULL check is reversed so it prints an error for success instead of failure.

Affected Software

8 affected componentsFixes available
Linux Linux kernel>=5.15.153<5.15.165
Linux Linux kernel>=6.0<6.1.103
Linux Linux kernel>=6.2<6.6.44
Linux Linux kernel>=6.7<6.10.3
debian/linux<6.1.106-1
6.1.106-1
debian/linux<6.10.3-1
6.10.3-1
debian/linux<6.10.3-1
6.10.3-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 5.10.223-1Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1
  2. Upgrade

    Upgrade debian/linux-6.1 to a version that resolves this vulnerability.

    Fixed in 6.1.129-1~deb11u1

Event History

Aug 21, 2024
CVE Published
via MITRE·12:06 AM
Data Sourced
via MITRE·12:06 AM
Description
Data Sourced
via NVD·01:15 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·01:15 AM
DescriptionSeverityAffected Software

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-43875?

CVE-2024-43875 has been classified with a moderate severity level due to potential inconsistencies in NULL checking.

2

How do I fix CVE-2024-43875?

To resolve CVE-2024-43875, you should upgrade to the fixed kernel versions: 5.10.223-1, 5.10.226-1, 6.1.123-1, 6.1.119-1, 6.12.10-1, or 6.12.11-1.

3

Which versions of Linux are affected by CVE-2024-43875?

CVE-2024-43875 affects various versions of the Linux kernel, specifically those prior to the specified remedy versions.

4

Is there a patch available for CVE-2024-43875?

Yes, patches have been applied in the updated kernel versions that remediate CVE-2024-43875.

5

What component of the Linux kernel does CVE-2024-43875 affect?

CVE-2024-43875 affects the PCI endpoint functionality within the Linux kernel.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203