CVE-2024-43894: drm/client: fix null pointer dereference in drm_client_modeset_probe

Published Aug 26, 2024
·
Updated

drm/client: fix null pointer dereference in drmclientmodesetprobe

Affected Software

15 affected componentsFixes available
Linux Linux kernel>=5.3<5.4.282
Linux Linux kernel>=5.5<5.10.224
Linux Linux kernel>=5.11<5.15.165
Linux Linux kernel>=5.16<6.1.105
Linux Linux kernel>=6.2<6.6.46
Linux Linux kernel>=6.7<6.10.5
Linux Linux kernel=6.11-rc1
Linux Linux kernel=6.11-rc2
Microsoft cbl2 kernel 5.15.164.1-1
Microsoft cbl2 kernel 5.15.167.1-1
Microsoft cbl2 kernel 5.15.164.1-1
debian/linux<6.1.106-1
6.1.106-1
debian/linux<6.10.6-1
6.10.6-1
debian/linux<6.10.6-1
6.10.6-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1
  2. Upgrade

    Upgrade debian/linux-6.1 to a version that resolves this vulnerability.

    Fixed in 6.1.129-1~deb11u1
  3. Compensating control

    In drm_client_modeset_probe(), check whether drm_mode_duplicate() returns NULL before assigning to or dereferencing modeset->mode, and handle the failure safely.

Event History

Aug 26, 2024
CVE Published
via MITRE·10:10 AM
Data Sourced
via MITRE·10:10 AM
Description
Data Sourced
via NVD·11:15 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·11:15 AM
DescriptionSeverityAffected Software
Oct 12, 2024
Data Sourced
via Microsoft·07:00 AM
DescriptionSeverityWeaknessAffected Software

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-43894?

CVE-2024-43894 has a severity rating that indicates it may lead to a null pointer dereference in certain conditions.

2

How do I fix CVE-2024-43894?

To resolve CVE-2024-43894, upgrade to the patched versions provided for the Linux kernel and related packages.

3

Which Linux kernel versions are vulnerable to CVE-2024-43894?

Linux kernel versions up to and including 5.10.223-1 and several versions in the 6.x series are vulnerable to CVE-2024-43894.

4

What impact does CVE-2024-43894 have on system operations?

CVE-2024-43894 can potentially cause crashes or lead to instability in systems using affected versions of the Linux kernel.

5

Can CVE-2024-43894 be exploited remotely?

While CVE-2024-43894 primarily concerns local exploitation through user-space applications, impacts may vary based on system configuration.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203