CVE-2024-43912: wifi: nl80211: disallow setting special AP channel widths
In the Linux kernel, the following vulnerability has been resolved:
wifi: nl80211: disallow setting special AP channel widths
Setting the AP channel width is meant for use with the normal 20/40/... MHz channel width progression, and switching around in S1G or narrow channels isn't supported. Disallow that.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1 - Upgrade
Upgrade
debian/linux-6.1to a version that resolves this vulnerability.Fixed in 6.1.129-1~deb11u1 - Configuration
Disallow setting special AP channel widths, including S1G or narrow-channel widths; use the normal 20/40/... MHz channel width progression.
Linux kernel wifi nl80211 AP channel width = normal 20/40/... MHz channel width progression
Event History
Frequently Asked Questions
What is the severity of CVE-2024-43912?
CVE-2024-43912 has a severity rating that indicates a potential impact on the security of affected systems using the Linux kernel.
How do I fix CVE-2024-43912?
To fix CVE-2024-43912, update your Linux kernel to the latest versions like 6.1.123-1, 6.1.119-1, or 6.12.11-1.
Which versions of Linux are affected by CVE-2024-43912?
CVE-2024-43912 affects various versions of the Linux kernel, specifically those below 6.1.105 and between 6.2 and 6.10.5.
What specific feature is involved in CVE-2024-43912?
CVE-2024-43912 involves the nl80211 feature related to restricting the setting of special access point channel widths.
What types of systems are impacted by CVE-2024-43912?
Systems running affected versions of the Linux kernel, particularly in wireless networking configurations, are impacted by CVE-2024-43912.