CVE-2024-44940: fou: remove warn in gue_gro_receive on unsupported protocol

Published Aug 26, 2024
·
Updated

fou: remove warn in guegroreceive on unsupported protocol

Other sources

This CVE was automatically created from a reference found in an email or other text. If you are reading this, then this CVE entry is probably erroneous, since this text should be replaced by the official CVE description automatically.

— Launchpad

Affected Software

11 affected componentsFixes available
Linux Linux kernel<6.6.47
Linux Linux kernel>=6.7<6.10.6
Microsoft cbl2 kernel 5.15.176.3-1
Microsoft cbl2 kernel 5.15.180.1-1
Microsoft cbl2 kernel 5.15.180.1-1
Debian Debian Linux=11.0
Linux Linux kernel>=3.18<5.10.234
Linux Linux kernel>=5.11<5.15.174
Linux Linux kernel>=5.16<6.1.107
Linux Linux kernel>=6.2<6.6.47
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-17.2.13-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1
  2. Upgrade

    Upgrade Linux kernel (fou: gue_gro_receive) to a version that resolves this vulnerability.

    Patch 270136613bf7

Event History

Aug 26, 2024
CVE Published
via MITRE·11:20 AM
Data Sourced
via MITRE·11:20 AM
DescriptionSeverity
Data Sourced
via NVD·12:15 PM
RemedyDescriptionSeverityAffected Software
Sep 4, 2025
Data Sourced
via Microsoft·07:03 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-44940?

CVE-2024-44940 is classified as a medium severity vulnerability in the Linux kernel.

2

How do I fix CVE-2024-44940?

To fix CVE-2024-44940, update to the recommended kernel versions provided in the remediation section.

3

Which versions of Linux kernel are affected by CVE-2024-44940?

CVE-2024-44940 affects Linux kernel versions up to 6.6.47 excluding, and from version 5.10.223-1 to 5.10.226-1 as well as certain versions of linux-6.1.

4

What components are vulnerable due to CVE-2024-44940?

The vulnerable components include the linux and linux-6.1 packages in specific versions as listed in the remediation.

5

Is CVE-2024-44940 exploitable remotely?

Yes, CVE-2024-44940 can be exploited using specially constructed packets.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203