CVE-2024-44947: fuse: Initialize beyond-EOF page contents before setting uptodate

Published Sep 2, 2024
·
Updated

fuse: Initialize beyond-EOF page contents before setting uptodate

Affected Software

16 affected componentsFixes available
Linux Linux kernel>=2.6.36<4.19.321
Linux Linux kernel>=4.20<5.4.283
Linux Linux kernel>=5.5<5.10.225
Linux Linux kernel>=5.11<5.15.166
Linux Linux kernel>=5.16<6.1.107
Linux Linux kernel>=6.2<6.6.48
Linux Linux kernel>=6.7<6.10.7
Linux Linux kernel=6.11-rc1
Linux Linux kernel=6.11-rc2
Linux Linux kernel=6.11-rc3
Microsoft cbl2 kernel 5.15.164.1-1
Microsoft azl3 kernel 6.6.51.1-1
Microsoft cbl2 kernel 5.15.164.1-1
Microsoft cbl2 kernel 5.15.167.1-1
Microsoft azl3 kernel 6.6.47.1-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-17.2.13-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1
  2. Configuration

    Enable init-on-alloc by setting CONFIG_INIT_ON_ALLOC_DEFAULT_ON=y, or by using the corresponding kernel command-line parameter.

    Linux kernel CONFIG_INIT_ON_ALLOC_DEFAULT_ON = y

Event History

Sep 2, 2024
CVE Published
via MITRE·05:36 PM
Data Sourced
via MITRE·05:36 PM
Description
Data Sourced
via NVD·06:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via Red Hat·06:20 PM
DescriptionSeverityAffected Software
Oct 12, 2024
Data Sourced
via Microsoft·07:00 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-44947?

CVE-2024-44947 has been rated as having a medium severity level due to its potential impact on the Linux kernel's behavior.

2

How do I fix CVE-2024-44947?

To fix CVE-2024-44947, update your Linux kernel to a version that includes the appropriate patches, such as 5.10.226-1 or 6.1.123-1.

3

Which Linux kernel versions are affected by CVE-2024-44947?

CVE-2024-44947 affects Linux kernel versions from 2.6.36 up to 6.11-rc3 across several ranges.

4

What component is primarily impacted by CVE-2024-44947?

CVE-2024-44947 primarily impacts the FUSE subsystem within the Linux kernel.

5

Is there a workaround for CVE-2024-44947?

Currently, there is no widely recognized workaround for CVE-2024-44947; patching the kernel is recommended.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203