CVE-2024-44996: vsock: fix recursive ->recvmsg calls

Published Sep 4, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

vsock: fix recursive ->recvmsg calls

After a vsock socket has been added to a BPF sockmap, its prot->recvmsg has been replaced with vsockbpfrecvmsg(). Thus the following recursiion could happen:

vsockbpfrecvmsg() -> vsockrecvmsg() -> vsockconnectiblerecvmsg() -> prot->recvmsg() -> vsockbpfrecvmsg() again

We need to fix it by calling the original ->recvmsg() without any BPF sockmap logic in vsockrecvmsg().

Affected Software

10 affected componentsFixes available
Linux Linux kernel>=6.4<6.6.48
Linux Linux kernel>=6.7<6.10.7
Linux Linux kernel=6.11-rc1
Linux Linux kernel=6.11-rc2
Linux Linux kernel=6.11-rc3
Microsoft azl3 kernel 6.6.47.1-1
Microsoft azl3 kernel 6.6.51.1-1
debian/linux<6.10.7-1
6.10.7-1
debian/linux<6.10.7-1
6.10.7-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 5.10.223-1Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1

Event History

Sep 4, 2024
CVE Published
via MITRE·07:54 PM
Data Sourced
via MITRE·07:54 PM
Description
Data Sourced
via OSV·08:15 PM
DescriptionSeverityAffected Software
Oct 15, 2024
Data Sourced
via Microsoft·07:00 AM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2024-44996?

CVE-2024-44996 has been classified with a medium severity due to the potential for recursive calls in the vsock implementation.

2

How do I fix CVE-2024-44996?

To fix CVE-2024-44996, you should upgrade the Linux kernel to a version that includes the patch for this vulnerability.

3

Which Linux kernel versions are affected by CVE-2024-44996?

CVE-2024-44996 affects Linux kernel versions from 6.4 to 6.6.48, and specific release candidates of 6.11.

4

What kind of systems are vulnerable to CVE-2024-44996?

Systems running vulnerable versions of the Linux kernel that utilize vsock sockets and BPF sockmaps are susceptible to CVE-2024-44996.

5

Is CVE-2024-44996 a remote exploit risk?

CVE-2024-44996 presents a risk of remote exploitation due to the nature of vsock sockets being used in network communications.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203