CVE-2024-45007: char: xillybus: Don't destroy workqueue from work item running on it

Published Sep 4, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

char: xillybus: Don't destroy workqueue from work item running on it

Triggered by a kref decrement, destroyworkqueue() may be called from within a work item for destroying its own workqueue. This illegal situation is averted by adding a module-global workqueue for exclusive use of the offending work item. Other work items continue to be queued on per-device workqueues to ensure performance.

Affected Software

8 affected componentsFixes available
Linux Linux kernel>=5.14<5.15.166
Linux Linux kernel>=5.16<6.1.107
Linux Linux kernel>=6.2<6.6.48
Linux Linux kernel>=6.7<6.10.7
Linux Linux kernel=6.11-rc1
Linux Linux kernel=6.11-rc2
Linux Linux kernel=6.11-rc3
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-17.2.13-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1
  2. Compensating control

    For the Linux kernel char/xillybus driver, add a module-global workqueue exclusively for the offending work item so it cannot destroy the per-device workqueue from a work item running on that same queue.

Event History

Sep 4, 2024
CVE Published
via MITRE·07:54 PM
Data Sourced
via MITRE·07:54 PM
Description
Data Sourced
via NVD·08:15 PM
RemedyDescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-45007?

CVE-2024-45007 has a medium severity rating due to its potential for causing instability in the Linux kernel.

2

How do I fix CVE-2024-45007?

To fix CVE-2024-45007, you should upgrade to the appropriate version of the Linux kernel as specified in the remediation details.

3

What are the affected versions for CVE-2024-45007?

CVE-2024-45007 affects Linux kernel versions up to but not including 5.10.224-1 and certain specific versions listed in the remediation.

4

Is CVE-2024-45007 exploitable in production environments?

Yes, CVE-2024-45007 is exploitable in production environments, particularly where the vulnerable versions of the Linux kernel are in use.

5

What impact does CVE-2024-45007 have on system performance?

CVE-2024-45007 may lead to system instability and unexpected behavior due to illegal workqueue management.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203