CVE-2024-45029: i2c: tegra: Do not mark ACPI devices as irq safe

Published Sep 11, 2024
·
Updated

i2c: tegra: Do not mark ACPI devices as irq safe

Affected Software

9 affected componentsFixes available
Linux Linux kernel>=5.17<6.1.107
Linux Linux kernel>=6.2<6.6.48
Linux Linux kernel>=6.7<6.10.7
Linux Linux kernel=6.11-rc1
Linux Linux kernel=6.11-rc2
Linux Linux kernel=6.11-rc3
Microsoft azl3 kernel 6.6.47.1-1
Microsoft azl3 kernel 6.6.51.1-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-17.2.13-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1
  2. Configuration

    Do not mark ACPI devices as IRQ-safe in the tegra I2C driver, because acpi_subsys_runtime_resume() relies on mutexes.

    Linux kernel tegra I2C driver on ACPI devices IRQ-safe marking = false

Event History

Sep 11, 2024
CVE Published
via MITRE·03:14 PM
Data Sourced
via MITRE·03:14 PM
Description
Data Sourced
via NVD·04:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Oct 15, 2024
Data Sourced
via Microsoft·07:00 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-45029?

CVE-2024-45029 is considered a medium severity vulnerability affecting the Linux kernel.

2

How do I fix CVE-2024-45029?

To mitigate CVE-2024-45029, users should upgrade to the recommended versions of the Linux kernel as specified in the vulnerability advisory.

3

Which Linux kernel versions are affected by CVE-2024-45029?

CVE-2024-45029 affects Linux kernel versions between 5.17 and 6.1.107, as well as between 6.2 and 6.6.48, among others.

4

What components are impacted by CVE-2024-45029?

The vulnerability primarily impacts the i2c module for Tegra on ACPI machines within the Linux kernel.

5

What are the potential consequences of CVE-2024-45029?

Exploitation of CVE-2024-45029 may lead to system instability due to improper locking mechanisms in the Linux kernel.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203