CVE-2024-45492: Integer Overflow
An issue was discovered in libexpat before 2.6.3. nextScaffoldPart in xmlparse.c can have an integer overflow for mgroupSize on 32-bit platforms (where UINTMAX equals SIZEMAX).
Other sources
libexpat could allow a local attacker to execute arbitrary code on the system, caused by an integer overflow in the nextScaffoldPart function in xmlparse.c. By sending a specially crafted request, an attacker could exploit this vulnerability to execute arbitrary code on the system.
— IBM
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/expatto a version that resolves this vulnerability.Fixed in 2.5.0-1+deb12u1 - Upgrade
Upgrade
debian/expatto a version that resolves this vulnerability.Fixed in 2.6.2-2 - Upgrade
Upgrade
alpine/expatto a version that resolves this vulnerability.Fixed in 2.6.3-r0 - Upgrade
Upgrade
alpine/qt5-qtwebengineto a version that resolves this vulnerability.Fixed in 5.15.16-r12 - Upgrade
Upgrade
alpine/qt5-qtwebengineto a version that resolves this vulnerability.Fixed in 5.15.17-r3 - Upgrade
Upgrade
alpine/qt6-qtwebengineto a version that resolves this vulnerability.Fixed in 6.7.2-r6 - Upgrade
Upgrade
debian/expatto a version that resolves this vulnerability.Fixed in 2.5.0-1+deb12u2Fixed in 2.5.0-1+deb12u5Fixed in 2.8.3-1~deb13u1Fixed in 2.9.0-1~deb13u1Fixed in 2.9.0-1Fixed in 2.10.0-1 - Upgrade
Upgrade
libexpatto a version that resolves this vulnerability.Fixed in 2.6.3
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2024-45492?
CVE-2024-45492 is classified with a severity that indicates a significant risk due to the integer overflow vulnerability in libexpat.
How do I fix CVE-2024-45492?
To fix CVE-2024-45492, upgrade libexpat to version 2.6.3 or later.
Which versions of libexpat are affected by CVE-2024-45492?
CVE-2024-45492 affects all versions of libexpat prior to 2.6.3.
Is CVE-2024-45492 exploited in the wild?
As of now, there is no public information available indicating that CVE-2024-45492 is actively being exploited in the wild.
What types of systems are vulnerable to CVE-2024-45492?
CVE-2024-45492 primarily affects 32-bit platforms due to the integer overflow issue in libexpat.