CVE-2024-47050: Mautic vulnerable to XSS in contact/company tracking (no authentication)

Published Sep 18, 2024
·
Updated

Summary Prior to this patch being applied, Mautic's tracking was vulnerable to Cross-Site Scripting through the Page URL variable. Patches Please update to 4.4.13 or 5.1.1 or later.

Workarounds None

References https://owasp.org/www-project-top-ten/2017/A72017-Cross-SiteScripting(XSS) https://owasp.org/www-project-web-security-testing-guide/latest/4-WebApplicationSecurityTesting/07-InputValidationTesting/02-TestingforStoredCrossSiteScripting

If you have any questions or comments about this advisory: Email us at security@mautic.org

Other sources

Mautic vulnerable to XSS in contact/company tracking (no authentication)

— Packagist

Affected Software

10 affected componentsFixes available
composer/mautic/core-lib>=5.0.0-alpha<5.1.1
5.1.1
composer/mautic/core-lib>=2.6.0<4.4.13
4.4.13
composer/mautic/core>=5.0.0-alpha<5.1.1
5.1.1
composer/mautic/core>=2.6.0<4.4.13
4.4.13
Acquia Mautic>=2.6.0<4.4.13
Acquia Mautic>=5.0.0<5.1.1
composer/mautic/core>=5.0.0-alpha, <5.1.1
5.1.1
composer/mautic/core>=2.6.0, <4.4.13
4.4.13
composer/mautic/core-lib>=5.0.0-alpha, <5.1.1
5.1.1
composer/mautic/core-lib>=2.6.0, <4.4.13
4.4.13

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/mautic/core-lib to a version that resolves this vulnerability.

    Fixed in 5.1.1
  2. Upgrade

    Upgrade composer/mautic/core-lib to a version that resolves this vulnerability.

    Fixed in 4.4.13
  3. Upgrade

    Upgrade composer/mautic/core to a version that resolves this vulnerability.

    Fixed in 5.1.1
  4. Upgrade

    Upgrade composer/mautic/core to a version that resolves this vulnerability.

    Fixed in 4.4.13
  5. Upgrade

    Upgrade Mautic to a version that resolves this vulnerability.

    Fixed in 4.4.13
  6. Upgrade

    Upgrade Mautic to a version that resolves this vulnerability.

    Fixed in 5.1.1

Event History

Sep 18, 2024
CVE Published
via MITRE·09:04 PM
Data Sourced
via MITRE·09:04 PM
RemedyDescriptionSeverityWeakness
Data Sourced
via NVD·09:15 PM
DescriptionSeverityWeaknessAffected Software
Advisory Published
via GitHub·10:05 PM
Data Sourced
via GitHub·10:05 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·10:05 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2024-47050?

CVE-2024-47050 is classified as a Cross-Site Scripting (XSS) vulnerability that can lead to potential data compromise.

2

How do I fix CVE-2024-47050?

To fix CVE-2024-47050, update Mautic to version 4.4.13 or 5.1.1 or later.

3

What software is affected by CVE-2024-47050?

CVE-2024-47050 affects Mautic versions prior to 4.4.13 and 5.1.1.

4

Are there any workarounds for CVE-2024-47050?

There are no known workarounds for CVE-2024-47050, so updating is essential.

5

What type of vulnerability is CVE-2024-47050?

CVE-2024-47050 is a Cross-Site Scripting (XSS) vulnerability impacting Mautic's tracking functionality.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203