CVE-2024-47059: Mautic allows users enumeration due to weak password login

Published Sep 18, 2024
·
Updated

Summary

When logging in with the correct username and incorrect weak password, the user receives the notification, that their password is too weak.

However when an incorrect username is provided along side with weak password, the application responds with ’Invalid credentials’ notification.

This difference could be used to perform username enumeration.

Patches

Update to 5.1.1 or later.

If you have any questions or comments about this advisory:

Email us at security@mautic.org

Other sources

Mautic allows users enumeration due to weak password login

— Packagist

When logging in with the correct username and incorrect weak password, the user receives the notification, that their password is too weak.

However when an incorrect username is provided alongside with a weak password, the application responds with ’Invalid credentials’ notification.

This difference could be used to perform username enumeration.

— MITRE

Affected Software

3 affected componentsFixes available
composer/mautic/core>=5.1.0<5.1.1
5.1.1
Acquia Mautic=5.1.0
composer/mautic/core>=5.1.0, <5.1.1
5.1.1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/mautic/core to a version that resolves this vulnerability.

    Fixed in 5.1.1
  2. Upgrade

    Upgrade Mautic to a version that resolves this vulnerability.

    Fixed in 5.1.1

Event History

Sep 18, 2024
CVE Published
via MITRE·09:19 PM
Data Sourced
via MITRE·09:19 PM
RemedyDescriptionSeverityWeakness
Advisory Published
via GitHub·10:10 PM
Data Sourced
via GitHub·10:10 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·10:10 PM
DescriptionSeverityAffected Software
Data Sourced
via NVD·10:15 PM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2024-47059?

CVE-2024-47059 has a moderate severity level due to issues related to weak password validation.

2

How do I fix CVE-2024-47059?

To fix CVE-2024-47059, update Mautic core to version 5.1.2 or later to enhance password validation mechanisms.

3

What impact does CVE-2024-47059 have on user authentication?

CVE-2024-47059 can allow attackers to exploit weak password implementations during authentication attempts.

4

Is CVE-2024-47059 being actively exploited?

As of now, there are no public reports indicating that CVE-2024-47059 is actively being exploited.

5

What versions of Mautic are affected by CVE-2024-47059?

CVE-2024-47059 affects Mautic core versions between 5.1.0 and 5.1.1 inclusive.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203