CVE-2024-47875: DOMPurify nesting-based mXSS
DOMPurify is a DOM-only, super-fast, uber-tolerant XSS sanitizer for HTML, MathML and SVG. DOMpurify was vulnerable to nesting-based mXSS. This vulnerability is fixed in 2.5.0 and 3.1.3.
Other sources
DOMpurify was vulnerable to nesting-based mXSS
fixed by 0ef5e537 (2.x) and merge 943
Backporter should be aware of GHSA-mmhx-hmjr-r674 (CVE-2024-45801) when cherry-picking
POC is avaible under test
— GitHub
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
npm/dompurifyto a version that resolves this vulnerability.Fixed in 3.1.3 - Upgrade
Upgrade
npm/dompurifyto a version that resolves this vulnerability.Fixed in 2.5.0 - Upgrade
Upgrade
debian/cactito a version that resolves this vulnerability.Fixed in 1.2.24+ds1-1+deb12u2 - Upgrade
Upgrade
debian/cactito a version that resolves this vulnerability.Fixed in 1.2.26+ds1-1 - Upgrade
Upgrade
debian/node-dompurifyto a version that resolves this vulnerability.Fixed in 2.4.1+dfsg+~2.4.0-2 - Upgrade
Upgrade
debian/node-dompurifyto a version that resolves this vulnerability.Fixed in 3.1.6+dfsg+~3.0.5-1 - Upgrade
Upgrade
debian/cactito a version that resolves this vulnerability.Fixed in 1.2.24+ds1-1+deb12u5Fixed in 1.2.30+ds1-1Fixed in 1.2.31+ds1-4 - Upgrade
Upgrade
debian/node-dompurifyto a version that resolves this vulnerability.Fixed in 2.4.1+dfsg+~2.4.0-2+deb12u1Fixed in 2.4.1+dfsg+~2.4.0-2Fixed in 3.1.7+dfsg+~3.0.5-2Fixed in 3.4.17+dfsg-1 - Upgrade
Upgrade
DOMPurifyto a version that resolves this vulnerability.Fixed in 2.5.0 - Upgrade
Upgrade
DOMPurifyto a version that resolves this vulnerability.Fixed in 3.1.3
Event History
Frequently Asked Questions
What is the severity of CVE-2024-47875?
The severity of CVE-2024-47875 is classified as high due to its potential for cross-site scripting attacks.
How do I fix CVE-2024-47875?
To fix CVE-2024-47875, update DOMPurify to version 2.5.0 or 3.1.3 or later.
What type of vulnerability is CVE-2024-47875?
CVE-2024-47875 is a nesting-based mXSS vulnerability affecting the DOMPurify library.
What versions of DOMPurify are affected by CVE-2024-47875?
CVE-2024-47875 affects DOMPurify versions between 3.0.0 and 3.1.2, as well as versions below 2.5.0.
Is CVE-2024-47875 a critical vulnerability?
Yes, CVE-2024-47875 is considered a critical vulnerability due to the risk of executing malicious scripts.