CVE-2024-47913: Improper permissions handling in MediaWiki AbuseFilter

Published Oct 4, 2024
·
Updated

An issue was discovered in the AbuseFilter extension for MediaWiki before 1.39.9, 1.40.x and 1.41.x before 1.41.3, and 1.42.x before 1.42.2. An API caller can match a filter condition against AbuseFilter logs even if the caller is not authorized to view the log details for the filter.

Other sources

Improper permissions handling in MediaWiki AbuseFilter

— Packagist

Affected Software

13 affected componentsFixes available
composer/mediawiki/abuse-filter>=1.42.0<1.42.2
1.42.2
composer/mediawiki/abuse-filter>=1.40.0<1.41.3
1.41.3
composer/mediawiki/abuse-filter<1.39.9
1.39.9
MediaWiki MediaWiki<1.39.9
MediaWiki MediaWiki>=1.40.0<1.41.3
MediaWiki MediaWiki>=1.42.0<1.42.2
composer/mediawiki/abuse-filter>=1.42.0, <1.42.2
1.42.2
composer/mediawiki/abuse-filter>=1.40.0, <1.41.3
1.41.3
composer/mediawiki/abuse-filter<1.39.9
1.39.9
debian/mediawiki<1:1.39.10-1~deb12u1
1:1.39.10-1~deb12u1
debian/mediawiki<1:1.39.10-1
1:1.39.10-1
debian/mediawiki<1:1.39.10-1
1:1.39.10-1
debian/mediawiki
1:1.39.17-1+deb12u21:1.43.9+dfsg-1~deb13u11:1.43.11+dfsg-3

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/mediawiki/abuse-filter to a version that resolves this vulnerability.

    Fixed in 1.42.2
  2. Upgrade

    Upgrade composer/mediawiki/abuse-filter to a version that resolves this vulnerability.

    Fixed in 1.41.3
  3. Upgrade

    Upgrade composer/mediawiki/abuse-filter to a version that resolves this vulnerability.

    Fixed in 1.39.9
  4. Upgrade

    Upgrade debian/mediawiki to a version that resolves this vulnerability.

    Fixed in 1:1.39.10-1~deb12u1
  5. Upgrade

    Upgrade debian/mediawiki to a version that resolves this vulnerability.

    Fixed in 1:1.39.10-1
  6. Upgrade

    Upgrade debian/mediawiki to a version that resolves this vulnerability.

    Fixed in 1:1.39.17-1+deb12u2Fixed in 1:1.43.9+dfsg-1~deb13u1Fixed in 1:1.43.11+dfsg-3

Event History

Oct 4, 2024
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via NVD·10:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·10:15 PM
DescriptionSeverityAffected Software
Oct 5, 2024
Advisory Published
via GitHub·12:34 AM
Data Sourced
via GitHub·12:34 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·12:34 AM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2024-47913?

CVE-2024-47913 is categorized as a moderate severity vulnerability affecting specific versions of the AbuseFilter extension for MediaWiki.

2

How do I fix CVE-2024-47913?

To fix CVE-2024-47913, upgrade the AbuseFilter extension to version 1.42.2 or later, or to 1.41.3, or to 1.39.9.

3

What versions of MediaWiki are affected by CVE-2024-47913?

CVE-2024-47913 affects MediaWiki versions before 1.39.9, 1.41.x before 1.41.3, and 1.42.x before 1.42.2.

4

What does CVE-2024-47913 allow an attacker to do?

CVE-2024-47913 allows an unauthorized API caller to match a filter condition against AbuseFilter logs.

5

Is there a known exploitation method for CVE-2024-47913?

Currently, no specific exploitation method for CVE-2024-47913 has been detailed, but it poses a risk of unauthorized data exposure.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203