CVE-2024-50005: mac802154: Fix potential RCU dereference issue in mac802154_scan_worker

Published Oct 21, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

mac802154: Fix potential RCU dereference issue in mac802154scanworker

In the mac802154scanworker function, the scanreq->type field was accessed after the RCU read-side critical section was unlocked. According to RCU usage rules, this is illegal and can lead to unpredictable behavior, such as accessing memory that has been updated or causing use-after-free issues.

This possible bug was identified using a static analysis tool developed by myself, specifically designed to detect RCU-related issues.

To address this, the scanreq->type value is now stored in a local variable scanreqtype while still within the RCU read-side critical section. The scanreqtype is then used after the RCU lock is released, ensuring that the type value is safely accessed without violating RCU rules.

Other sources

This CVE was automatically created from a reference found in an email or other text. If you are reading this, then this CVE entry is probably erroneous, since this text should be replaced by the official CVE description automatically.

— Launchpad

Affected Software

9 affected componentsFixes available
Linux Linux kernel>=6.5<6.6.55
Linux Linux kernel>=6.7<6.10.14
Linux Linux kernel>=6.11<6.11.3
Linux Linux kernel=6.12-rc1
Microsoft azl3 kernel 6.6.57.1-2
Microsoft azl3 kernel 6.6.51.1-5
debian/linux<6.11.4-1
6.11.4-1
debian/linux<6.11.4-1
6.11.4-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.11.4-1
  2. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1

Event History

Oct 21, 2024
CVE Published
via MITRE·06:53 PM
Data Sourced
via MITRE·06:53 PM
Description
Data Sourced
via OSV·07:15 PM
DescriptionSeverityAffected Software
Nov 12, 2024
Data Sourced
via Microsoft·08:00 AM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2024-50005?

The severity of CVE-2024-50005 is high due to potential RCU dereference issues in the Linux kernel.

2

How do I fix CVE-2024-50005?

To fix CVE-2024-50005, update to the latest version of the Linux kernel that addresses this vulnerability.

3

What versions of Linux kernel are affected by CVE-2024-50005?

CVE-2024-50005 affects Linux kernel versions between 6.5 to 6.6.55, 6.7 to 6.10.14, and 6.11 to 6.11.3, as well as version 6.12-rc1.

4

What components are involved in CVE-2024-50005?

CVE-2024-50005 specifically involves the mac802154 component within the Linux kernel.

5

What is the nature of the vulnerability in CVE-2024-50005?

The nature of the vulnerability in CVE-2024-50005 involves accessing a field after leaving an RCU read-side critical section, leading to potential dereference issues.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203