CVE-2024-50345: Open redirect via browser-sanitized URLs

Published Nov 5, 2024
·
Updated

Description

The Request class, does not parse URI with special characters the same way browsers do. As a result, an attacker can trick a validator relying on the Request class to redirect users to another domain.

Resolution

The Request::create methods now assert the URI does not contain invalid characters as defined by https://url.spec.whatwg.org/

The patch for this issue is available here for branch 5.4.

Credits

We would like to thank Sam Mush - IPASSLab && ZGC Lab for reporting the issue and Nicolas Grekas for providing the fix.

Other sources

CVE-2024-50345: Open redirect via browser-sanitized URLs

— Packagist

symfony/http-foundation is a module for the Symphony PHP framework which defines an object-oriented layer for the HTTP specification. The Request class, does not parse URI with special characters the same way browsers do. As a result, an attacker can trick a validator relying on the Request class to redirect users to another domain. The Request::create methods now assert the URI does not contain invalid characters as defined by https://url.spec.whatwg.org/. This issue has been patched in versions 5.4.46, 6.4.14, and 7.1.7. Users are advised to upgrade. There are no known workarounds for this vulnerability.

— NVD

Affected Software

40 affected componentsFixes available
composer/symfony/http-foundation>=7.0.0<7.1.7
7.1.7
composer/symfony/http-foundation>=6.0.0<6.4.14
6.4.14
composer/symfony/http-foundation<5.4.46
5.4.46
SensioLabs Symfony<5.4.46
SensioLabs Symfony>=6.0.0<6.4.14
SensioLabs Symfony>=7.0.0<7.1.7
composer/symfony/http-foundation>=2.0.0, <3.0.0
composer/symfony/http-foundation>=3.0.0, <4.0.0
composer/symfony/http-foundation>=4.0.0, <5.0.0
composer/symfony/http-foundation>=5.0.0, <5.1.0
composer/symfony/http-foundation>=5.1.0, <5.2.0
composer/symfony/http-foundation>=5.2.0, <5.3.0
composer/symfony/http-foundation>=5.3.0, <5.4.0
composer/symfony/http-foundation>=5.4.0, <5.4.46
5.4.46
composer/symfony/http-foundation>=6.0.0, <6.1.0
composer/symfony/http-foundation>=6.1.0, <6.2.0
composer/symfony/http-foundation>=6.2.0, <6.3.0
composer/symfony/http-foundation>=6.3.0, <6.4.0
composer/symfony/http-foundation>=6.4.0, <6.4.14
6.4.14
composer/symfony/http-foundation>=7.0.0, <7.1.0
composer/symfony/http-foundation>=7.1.0, <7.1.7
7.1.7
composer/symfony/symfony>=2.0.0, <3.0.0
composer/symfony/symfony>=3.0.0, <4.0.0
composer/symfony/symfony>=4.0.0, <5.0.0
composer/symfony/symfony>=5.0.0, <5.1.0
composer/symfony/symfony>=5.1.0, <5.2.0
composer/symfony/symfony>=5.2.0, <5.3.0
composer/symfony/symfony>=5.3.0, <5.4.0
composer/symfony/symfony>=5.4.0, <5.4.46
5.4.46
composer/symfony/symfony>=6.0.0, <6.1.0
composer/symfony/symfony>=6.1.0, <6.2.0
composer/symfony/symfony>=6.2.0, <6.3.0
composer/symfony/symfony>=6.3.0, <6.4.0
composer/symfony/symfony>=6.4.0, <6.4.14
6.4.14
composer/symfony/symfony>=7.0.0, <7.1.0
composer/symfony/symfony>=7.1.0, <7.1.7
7.1.7
debian/symfony<5.4.23+dfsg-1+deb12u3
5.4.23+dfsg-1+deb12u3
debian/symfony<6.4.14+dfsg-1
6.4.14+dfsg-1
debian/symfony<6.4.14+dfsg-1
6.4.14+dfsg-1
debian/symfony
5.4.53+dfsg-0+deb12u16.4.41+dfsg-0+deb13u16.4.49+dfsg-0+deb13u17.4.22+dfsg-17.4.23+dfsg-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/symfony/http-foundation to a version that resolves this vulnerability.

    Fixed in 7.1.7
  2. Upgrade

    Upgrade composer/symfony/http-foundation to a version that resolves this vulnerability.

    Fixed in 6.4.14
  3. Upgrade

    Upgrade composer/symfony/http-foundation to a version that resolves this vulnerability.

    Fixed in 5.4.46
  4. Upgrade

    Upgrade composer/symfony/symfony to a version that resolves this vulnerability.

    Fixed in 5.4.46
  5. Upgrade

    Upgrade composer/symfony/symfony to a version that resolves this vulnerability.

    Fixed in 6.4.14
  6. Upgrade

    Upgrade composer/symfony/symfony to a version that resolves this vulnerability.

    Fixed in 7.1.7
  7. Upgrade

    Upgrade debian/symfony to a version that resolves this vulnerability.

    Fixed in 5.4.23+dfsg-1+deb12u3
  8. Upgrade

    Upgrade debian/symfony to a version that resolves this vulnerability.

    Fixed in 6.4.14+dfsg-1
  9. Upgrade

    Upgrade debian/symfony to a version that resolves this vulnerability.

    Fixed in 5.4.53+dfsg-0+deb12u1Fixed in 6.4.41+dfsg-0+deb13u1Fixed in 6.4.49+dfsg-0+deb13u1Fixed in 7.4.22+dfsg-1Fixed in 7.4.23+dfsg-1
  10. Upgrade

    Upgrade symfony/http-foundation to a version that resolves this vulnerability.

    Fixed in 5.4.46
  11. Upgrade

    Upgrade symfony/http-foundation to a version that resolves this vulnerability.

    Fixed in 6.4.14
  12. Upgrade

    Upgrade symfony/http-foundation to a version that resolves this vulnerability.

    Fixed in 7.1.7

Event History

Nov 5, 2024
Advisory Published
via Packagist·08:00 AM
Data Sourced
via Packagist·08:00 AM
DescriptionSeverityAffected Software
Nov 6, 2024
Advisory Published
via GitHub·03:22 PM
CVE Published
via MITRE·08:56 PM
Data Sourced
via MITRE·08:56 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·09:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·09:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-50345?

The severity of CVE-2024-50345 is considered high due to the potential for attackers to manipulate redirects.

2

How do I fix CVE-2024-50345?

To fix CVE-2024-50345, update the symfony/http-foundation package to version 7.1.7, 6.4.14, or 5.4.46 depending on your current installation.

3

Which versions of symfony/http-foundation are affected by CVE-2024-50345?

Versions of symfony/http-foundation from 5.0.0 to 5.4.45, from 6.0.0 to 6.4.13, and from 7.0.0 to 7.1.6 are affected by CVE-2024-50345.

4

What type of vulnerability is CVE-2024-50345 classified as?

CVE-2024-50345 is classified as a URI manipulation vulnerability.

5

What can an attacker gain by exploiting CVE-2024-50345?

An attacker exploiting CVE-2024-50345 can redirect users to malicious domains by tricking a validator relying on the Request class.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203