CVE-2024-51739: Users enumeration allowed through Rest API in Combodo iTop
Combodo iTop is a simple, web based IT Service Management tool. Unauthenticated user can perform users enumeration, which can make it easier to bruteforce a valid account. As a fix the sentence displayed after resetting password no longer shows if the user exists or not. This fix is included in versions 2.7.11, 3.0.5, 3.1.2, and 3.2.0. Users are advised to upgrade. Users unable to upgrade may overload the dictionary entry "UI:ResetPwd-Error-WrongLogin" through an extension and replace it with a generic message.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Combodo iTopto a version that resolves this vulnerability.Fixed in 2.7.11 - Upgrade
Upgrade
Combodo iTopto a version that resolves this vulnerability.Fixed in 3.0.5 - Upgrade
Upgrade
Combodo iTopto a version that resolves this vulnerability.Fixed in 3.1.2 - Upgrade
Upgrade
Combodo iTopto a version that resolves this vulnerability.Fixed in 3.2.0 - Configuration
For installations unable to upgrade, overload the UI:ResetPwd-Error-WrongLogin dictionary entry through an extension and replace it with a generic message.
Combodo iTop UI:ResetPwd-Error-WrongLogin = generic message
Event History
Frequently Asked Questions
What is the severity of CVE-2024-51739?
CVE-2024-51739 has been classified as a medium severity vulnerability due to its potential misuse for user enumeration.
How do I fix CVE-2024-51739?
To fix CVE-2024-51739, update Combodo iTop to version 2.7.11 or later, or to any version between 3.0.0 and 3.0.5, or 3.1.0 and 3.1.2.
What impact does CVE-2024-51739 have on my system?
CVE-2024-51739 allows unauthenticated users to enumerate valid usernames, which increases the risk of brute-force password attacks.
Which versions of Combodo iTop are affected by CVE-2024-51739?
CVE-2024-51739 affects versions of Combodo iTop prior to 2.7.11, as well as specific versions between 3.0.0 to 3.0.5 and 3.1.0 to 3.1.2.
Is CVE-2024-51739 related to password security?
Yes, CVE-2024-51739 is directly related to password security as it facilitates user enumeration, making it easier to identify valid accounts for brute-force attacks.