CVE-2024-52333: Buffer Overflow
An improper array index validation vulnerability exists in the determineMinMax functionality of OFFIS DCMTK 3.6.8. A specially crafted DICOM file can lead to an out-of-bounds write. An attacker can provide a malicious file to trigger this vulnerability.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/dcmtkto a version that resolves this vulnerability.Fixed in 3.6.7-9~deb12u2 - Upgrade
Upgrade
debian/dcmtkto a version that resolves this vulnerability.Fixed in 3.6.8-7 - Upgrade
Upgrade
debian/dcmtkto a version that resolves this vulnerability.Fixed in 3.6.7-9~deb12u4Fixed in 3.6.9-5+deb13u3Fixed in 3.7.0+really3.7.0-7
Event History
Frequently Asked Questions
What is the severity of CVE-2024-52333?
CVE-2024-52333 has a high severity due to its potential for out-of-bounds writes that can be exploited by attackers.
How do I fix CVE-2024-52333?
To fix CVE-2024-52333, update OFFIS DCMTK to the latest version where the vulnerability has been addressed.
What products are affected by CVE-2024-52333?
CVE-2024-52333 affects OFFIS DCMTK version 3.6.8 and prior versions.
What type of attack can exploit CVE-2024-52333?
CVE-2024-52333 can be exploited by an attacker supplying a specially crafted DICOM file.
What is the impact of CVE-2024-52333 on system security?
The impact of CVE-2024-52333 includes potential data corruption or unauthorized access due to out-of-bounds writes.