CVE-2024-52530: High severity IBM Edge Application Manager vulnerability

Published Nov 11, 2024
·
Updated

GNOME libsoup before 3.6.0 allows HTTP request smuggling in some configurations

Affected Software

12 affected componentsFixes available
IBM Edge Application Manager<=4.5
Gnome libsoup<3.6.0
Microsoft cbl2 libsoup 3.0.4-2<3.0.4-2
3.0.4-2
Microsoft cbl2 libsoup 3.0.4-6<3.0.4-2
3.0.4-2
Microsoft azl3 libsoup 3.4.4-6<3.4.4-2
3.4.4-2
Microsoft azl3 libsoup 3.4.4-2<3.4.4-2
3.4.4-2
debian/libsoup2.4<2.74.3-1+deb12u1
2.74.3-1+deb12u1
debian/libsoup2.4<2.74.3-8.1
2.74.3-8.1
debian/libsoup3<3.2.3-0+deb12u1
3.2.3-0+deb12u1
debian/libsoup3<3.5.2-1
3.5.2-1
debian/libsoup2.4
2.74.3-1+deb12u12.74.3-10.1
debian/libsoup3
3.2.3-0+deb12u23.6.5-33.8.0-3

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 3.0.4-2
  2. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 3.4.4-2
  3. Upgrade

    Upgrade debian/libsoup2.4 to a version that resolves this vulnerability.

    Fixed in 2.74.3-1+deb12u1
  4. Upgrade

    Upgrade debian/libsoup2.4 to a version that resolves this vulnerability.

    Fixed in 2.74.3-8.1
  5. Upgrade

    Upgrade debian/libsoup3 to a version that resolves this vulnerability.

    Fixed in 3.2.3-0+deb12u1
  6. Upgrade

    Upgrade debian/libsoup3 to a version that resolves this vulnerability.

    Fixed in 3.5.2-1
  7. Upgrade

    Upgrade debian/libsoup2.4 to a version that resolves this vulnerability.

    Fixed in 2.74.3-1+deb12u1Fixed in 2.74.3-10.1
  8. Upgrade

    Upgrade debian/libsoup3 to a version that resolves this vulnerability.

    Fixed in 3.2.3-0+deb12u2Fixed in 3.6.5-3Fixed in 3.8.0-3
  9. Upgrade

    Upgrade GNOME libsoup to a version that resolves this vulnerability.

    Fixed in 3.6.0

Event History

Nov 11, 2024
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via Red Hat·08:01 PM
DescriptionSeverityAffected Software
Data Sourced
via NVD·08:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·08:15 PM
DescriptionSeverityAffected Software
Nov 20, 2024
Data Sourced
via Microsoft·08:00 AM
DescriptionSeverityWeaknessAffected Software
Aug 20, 2025
Data Sourced
via IBM·12:00 AM
DescriptionAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-52530?

CVE-2024-52530 is classified as a critical vulnerability due to its potential for HTTP request smuggling.

2

How do I fix CVE-2024-52530?

To fix CVE-2024-52530, upgrade to libsoup version 3.6.1-1 or later.

3

Which versions of libsoup are affected by CVE-2024-52530?

CVE-2024-52530 affects libsoup versions prior to 3.6.0, particularly libsoup2.4 and libsoup3 versions up to 3.2.2-2.

4

Is CVE-2024-52530 applicable to Debian users?

Yes, Debian users running affected versions of libsoup should upgrade to mitigate CVE-2024-52530.

5

What type of attack can CVE-2024-52530 facilitate?

CVE-2024-52530 can facilitate HTTP request smuggling attacks, potentially allowing malicious requests to bypass security controls.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203