CVE-2024-53073: NFSD: Never decrement pending_async_copies on error
In the Linux kernel, the following vulnerability has been resolved:
NFSD: Never decrement pendingasynccopies on error
The error flow in nfsd4copy() calls cleanupasynccopy(), which already decrements nn->pendingasynccopies.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.11.7-1 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1 - Upgrade
Upgrade
linux/Kernelto a version that resolves this vulnerability.Fixed in 6.11.7
Event History
Frequently Asked Questions
What is the severity of CVE-2024-53073?
CVE-2024-53073 has a severity rating that typically reflects the impact on the Linux kernel's handling of pending async copies.
How do I fix CVE-2024-53073?
To fix CVE-2024-53073, update the Linux kernel to version 6.11.7 or later.
What is the impact of CVE-2024-53073?
CVE-2024-53073 can potentially lead to incorrect handling of asynchronous operations in the Linux kernel.
Which versions of the Linux kernel are affected by CVE-2024-53073?
CVE-2024-53073 affects Linux kernel versions between 6.11.3 and 6.11.7.
Is there a workaround for CVE-2024-53073?
There is no specific workaround for CVE-2024-53073 other than applying the appropriate kernel update.