CVE-2024-53104: Linux Kernel Out-of-Bounds Write Vulnerability

Published Dec 2, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

media: uvcvideo: Skip parsing frames of type UVCVSUNDEFINED in uvcparseformat

This can lead to out of bounds writes since frames of this type were not taken into account when calculating the size of the frames buffer in uvcparsestreaming.

Other sources

In uvcparseformat of uvcdriver.c, there is a possible out of bounds write due to a heap buffer overflow. This could lead to physical escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.

— OSV

Linux kernel contains an out-of-bounds write vulnerability in the uvcparsestreaming component of the USB Video Class (UVC) driver that could allow for physical escalation of privilege.

— CISA

This CVE was automatically created from a reference found in an email or other text. If you are reading this, then this CVE entry is probably erroneous, since this text should be replaced by the official CVE description automatically.

— Launchpad

Affected Software

17 affected componentsFixes available
Linux Kernel
Debian Debian Linux=11.0
Linux Linux kernel>=2.6.26<4.19.324
Linux Linux kernel>=4.20<5.4.286
Linux Linux kernel>=5.5<5.10.230
Linux Linux kernel>=5.11<5.15.172
Linux Linux kernel>=5.16<6.1.117
Linux Linux kernel>=6.2<6.6.61
Linux Linux kernel>=6.7<6.11.8
Linux Linux kernel>=6.12<6.12.1
Google Android
Linux Kernel
android/:linux_kernel:>=:0<:2025-02-05
:2025-02-05
debian/linux<6.1.119-1
6.1.119-1
debian/linux<6.11.9-1
6.11.9-1
debian/linux<6.11.9-1
6.11.9-1
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.27-1
  2. Upgrade

    Upgrade debian/linux-6.1 to a version that resolves this vulnerability.

    Fixed in 6.1.129-1~deb11u1
  3. Upgrade

    Upgrade android/:linux_kernel: to a version that resolves this vulnerability.

    Fixed in :2025-02-05
  4. Configuration

    Block autoloading of the uvcvideo module by adding the line `blacklist uvcvideo` to `/etc/modprobe.d/blacklist.conf`.

    Linux kernel uvcvideo module module autoloading = blacklisted

Event History

Dec 4, 2023
News Published
via The Register·06:01 AM
Dec 18, 2023
News Published
via The Register·02:25 AM
Jan 15, 2024
News Published
via The Register·03:34 PM
Apr 29, 2024
News Published
via The Register·02:29 AM
May 6, 2024
News Published
via The Register·02:30 AM
May 13, 2024
News Published
via The Register·02:21 AM
Jun 3, 2024
News Published
via The Register·12:02 PM
Jul 1, 2024
News Published
via The Register·03:35 AM
Jul 22, 2024
News Published
via The Register·03:44 AM
Sep 30, 2024
News Published
via The Register·03:02 AM
Nov 11, 2024
News Published
via The Register·03:28 AM
Dec 2, 2024
CVE Published
via MITRE·07:29 AM
Data Sourced
via MITRE·07:29 AM
Description
Data Sourced
via Red Hat·08:00 AM
DescriptionSeverityAffected Software
Data Sourced
via NVD·08:15 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·08:15 AM
DescriptionSeverityAffected Software
Feb 1, 2025
Advisory Published
via OSV·12:00 AM
Feb 3, 2025
Data Sourced
via Android·12:00 AM
SeverityWeaknessAffected Software
News Published
via BleepingComputer·08:10 PM
Feb 4, 2025
News Published
via The Register·08:18 AM
Feb 5, 2025
Data Sourced
via CISA·12:00 AM
RemedyDescriptionWeaknessAffected Software
News Published
via BleepingComputer·06:58 PM
Feb 10, 2025
News Published
via The Register·02:30 AM
Feb 28, 2025
News Published
via BleepingComputer·04:27 PM
Mar 3, 2025
News Published
via The Register·03:31 AM
Mar 4, 2025
News Published
via BleepingComputer·11:38 AM
Apr 7, 2025
News Published
via BleepingComputer·05:55 PM
Sep 8, 2025
News Published
via The Register·11:46 AM

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2024-53104?

CVE-2024-53104 is classified as a high severity vulnerability due to its potential for out of bounds writes.

2

How do I fix CVE-2024-53104?

To fix CVE-2024-53104, you should update your Linux kernel to the patched version that addresses this vulnerability.

3

Which versions of the Linux kernel are affected by CVE-2024-53104?

CVE-2024-53104 affects multiple versions of the Linux kernel before the releases that contain the patch.

4

What are the potential impacts of CVE-2024-53104?

The potential impacts of CVE-2024-53104 include system instability and unauthorized access due to out of bounds memory writes.

5

Is CVE-2024-53104 publicly known?

Yes, CVE-2024-53104 is a publicly disclosed vulnerability affecting the Linux kernel.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203