CVE-2024-53201: drm/amd/display: Fix null check for pipe_ctx->plane_state in dcn20_program_pipe
drm/amd/display: Fix null check for pipectx->planestate in dcn20programpipe
Other sources
This CVE was automatically created from a reference found in an email or other text. If you are reading this, then this CVE entry is probably erroneous, since this text should be replaced by the official CVE description automatically.
— Launchpad
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.12.3-1 - Upgrade
Upgrade
linux/Kernelto a version that resolves this vulnerability.Fixed in 6.6.160 - Upgrade
Upgrade
linux/Kernelto a version that resolves this vulnerability.Fixed in 6.11.11 - Upgrade
Upgrade
linux/Kernelto a version that resolves this vulnerability.Fixed in 6.12.2 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1 - Compensating control
Add null checks for pipe_ctx->plane_state before accessing plane_state attributes in dcn20_program_pipe() and dcn20_update_dchubp_dpp().
Event History
Frequently Asked Questions
What is the severity of CVE-2024-53201?
CVE-2024-53201 has been classified as a high severity vulnerability due to the potential for a null pointer dereference leading to system crashes.
Which versions of the Linux kernel are affected by CVE-2024-53201?
CVE-2024-53201 affects Linux kernel versions from 6.6.64 to 6.7, from 6.11.3 to 6.11.11, and from 6.12 to 6.12.2.
How do I fix CVE-2024-53201?
To fix CVE-2024-53201, update the Linux kernel to a version that is not affected, such as 6.7 or higher for the 6.6 branch.
What does CVE-2024-53201 impact in the Linux kernel?
CVE-2024-53201 impacts the AMD display driver within the Linux kernel, specifically affecting the dcn20_program_pipe function.
Is it safe to use affected versions of the Linux kernel with CVE-2024-53201?
Using affected versions of the Linux kernel with CVE-2024-53201 is not safe as it can lead to system instability and crashes.