CVE-2024-55924: TYPO3 Scheduler Module vulnerable to Cross-Site Request Forgery

Published Jan 14, 2025
·
Updated

Problem A vulnerability has been identified in the backend user interface functionality involving deep links. Specifically, this functionality is susceptible to Cross-Site Request Forgery (CSRF). Additionally, state-changing actions in downstream components incorrectly accepted submissions via HTTP GET and did not enforce the appropriate HTTP method.

Successful exploitation of this vulnerability requires the victim to have an active session on the backend user interface and to be deceived into interacting with a malicious URL targeting the backend, which can occur under the following conditions:

the user opens a malicious link, such as one sent via email. the user visits a compromised or manipulated website while the following settings are misconfigured: + security.backend.enforceReferrer feature is disabled, + BE/cookieSameSite configuration is set to lax or none

The vulnerability in the affected downstream component “Scheduler Module” allows attackers to trigger pre-defined command classes - which can lead to unauthorized import or export of data in the worst case.

Solution Update to TYPO3 versions 11.5.42 ELTS that fixes the problem described.

Credits Thanks to Gabriel Dimitrov who reported this issue and to TYPO3 core and security members Benjamin Franzke, Oliver Hader, Andreas Kienast, Torben Hansen, Elias Häußler who fixed the issue.

Other sources

TYPO3 is a free and open source Content Management Framework. A vulnerability has been identified in the backend user interface functionality involving deep links. Specifically, this functionality is susceptible to Cross-Site Request Forgery (CSRF). Additionally, state-changing actions in downstream components incorrectly accepted submissions via HTTP GET and did not enforce the appropriate HTTP method. Successful exploitation of this vulnerability requires the victim to have an active session on the backend user interface and to be deceived into interacting with a malicious URL targeting the backend, which can occur under the following conditions: The user opens a malicious link, such as one sent via email. The user visits a compromised or manipulated website while the following settings are misconfigured: 1. security.backend.enforceReferrer feature is disabled, 2. BE/cookieSameSite configuration is set to lax or none. The vulnerability in the affected downstream component “Scheduler Module” allows attackers to trigger pre-defined command classes - which can lead to unauthorized import or export of data in the worst case. Users are advised to update to TYPO3 versions 11.5.42 ELTS which fixes the problem described. There are no known workarounds for this vulnerability.

— NVD

TYPO3 Scheduler Module vulnerable to Cross-Site Request Forgery

— Packagist

Affected Software

3 affected componentsFixes available
composer/typo3/cms-scheduler>=11.0.0<=11.5.41
11.5.42
Typo3 TYPO3>=11.0.0<11.5.42
composer/typo3/cms-scheduler>=11.0.0, <=11.5.41

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/typo3/cms-scheduler to a version that resolves this vulnerability.

    Fixed in 11.5.42
  2. Upgrade

    Upgrade TYPO3 to a version that resolves this vulnerability.

    Fixed in 11.5.42 ELTS

Event History

Jan 14, 2025
Advisory Published
via GitHub·03:42 PM
Data Sourced
via GitHub·03:42 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·03:42 PM
DescriptionSeverityAffected Software
CVE Published
via MITRE·07:16 PM
Data Sourced
via MITRE·07:16 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·08:15 PM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2024-55924?

CVE-2024-55924 is classified as a medium severity vulnerability due to its potential exploitation in Cross-Site Request Forgery attacks.

2

How do I fix CVE-2024-55924?

To fix CVE-2024-55924, upgrade the TYPO3 CMS Scheduler package to version 11.5.42 or later.

3

Which versions of TYPO3 are affected by CVE-2024-55924?

CVE-2024-55924 affects TYPO3 versions from 11.0.0 to 11.5.41.

4

What type of vulnerability is CVE-2024-55924?

CVE-2024-55924 is specifically a Cross-Site Request Forgery (CSRF) vulnerability.

5

What components are impacted by CVE-2024-55924?

CVE-2024-55924 impacts the backend user interface functionality of the TYPO3 CMS, particularly involving deep links.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203