CVE-2024-57804: scsi: mpi3mr: Fix corrupt config pages PHY state is switched in sysfs

Published Jan 11, 2025
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

scsi: mpi3mr: Fix corrupt config pages PHY state is switched in sysfs

The driver, through the SAS transport, exposes a sysfs interface to enable/disable PHYs in a controller/expander setup. When multiple PHYs are disabled and enabled in rapid succession, the persistent and current config pages related to SAS IO unit/SAS Expander pages could get corrupted.

Use separate memory for each config request.

Other sources

This CVE was automatically created from a reference found in an email or other text. If you are reading this, then this CVE entry is probably erroneous, since this text should be replaced by the official CVE description automatically.

— Launchpad

Affected Software

10 affected componentsFixes available
Linux Linux kernel
Linux Linux kernel>=6.1<6.12.8
Linux Linux kernel=6.13-rc1
debian/linux*
debian/linux<6.12.8-1
6.12.8-1
debian/linux<6.12.8-1
6.12.8-1
linux/kernel>=6.1.0<6.1.191
6.1.191
linux/kernel>=6.2.0<6.6.160
6.6.160
linux/kernel>=6.7.0<6.12.8
6.12.8
debian/linux<=6.1.176-1, <=6.1.190-1
6.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.12.8-1
  2. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.14-1
  3. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 6.1.191
  4. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 6.6.160
  5. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 6.12.8

Event History

Jan 11, 2025
CVE Published
via MITRE·12:39 PM
Data Sourced
via MITRE·12:39 PM
DescriptionSeverity
Data Sourced
via OSV·12:39 PM
DescriptionSeverityAffected Software
Data Sourced
via NVD·01:15 PM
RemedyDescriptionSeverityAffected Software
Sep 4, 2025
Data Sourced
via Microsoft·12:29 AM
DescriptionSeverityWeakness

Frequently Asked Questions

1

What is the severity of CVE-2024-57804?

CVE-2024-57804 is categorized as a low severity vulnerability in the Linux kernel.

2

How do I fix CVE-2024-57804?

To fix CVE-2024-57804, ensure that you update your Linux kernel to the latest stable release that contains the patch.

3

What component of the Linux kernel is affected by CVE-2024-57804?

CVE-2024-57804 affects the SCSI MPI3MR driver within the Linux kernel.

4

What type of vulnerability is CVE-2024-57804?

CVE-2024-57804 is a vulnerability related to the sysfs interface for enabling and disabling PHYs in a controller/expander setup.

5

Does CVE-2024-57804 require immediate attention?

While CVE-2024-57804 has a low severity rating, it is advisable to apply the patch to maintain system integrity.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203