CVE-2024-6162: Undertow: url-encoded request path information can be broken on ajp-listener

Published Jun 19, 2024
·
Updated

A vulnerability was found in Undertow, where URL-encoded request paths can be mishandled during concurrent requests on the AJP listener. This issue arises because the same buffer is used to decode the paths for multiple requests simultaneously, leading to incorrect path information being processed. As a result, the server may attempt to access the wrong path, causing errors such as "404 Not Found" or other application failures. This flaw can potentially lead to a denial of service, as legitimate resources become inaccessible due to the path mix-up.

Other sources

URL-encoded request path information can be broken for concurrent requests on ajp-listener causing the wrong path to be processed ending in a possible denial of service.

— Red Hat

Affected Software

4 affected componentsFixes available
maven/io.undertow:undertow-core<2.2.33.Final
2.2.33.Final
maven/io.undertow:undertow-core>=2.3.0.Alpha1<2.3.14.Final
2.3.14.Final
debian/undertow<2.3.18-1
2.3.18-1
debian/undertow
2.3.20-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade maven/io.undertow:undertow-core to a version that resolves this vulnerability.

    Fixed in 2.2.33.Final
  2. Upgrade

    Upgrade maven/io.undertow:undertow-core to a version that resolves this vulnerability.

    Fixed in 2.3.14.Final
  3. Upgrade

    Upgrade debian/undertow to a version that resolves this vulnerability.

    Fixed in 2.3.18-1
  4. Upgrade

    Upgrade debian/undertow to a version that resolves this vulnerability.

    Fixed in 2.3.20-1

Event History

Jun 19, 2024
Data Sourced
via Red Hat·12:43 PM
DescriptionSeverityAffected Software
Jun 20, 2024
CVE Published
via MITRE·02:33 PM
Data Sourced
via MITRE·02:33 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·03:15 PM
DescriptionSeverityWeakness
Data Sourced
via OSV·03:15 PM
DescriptionSeverityAffected Software
Advisory Published
via GitHub·03:31 PM

Frequently Asked Questions

1

What is the severity of CVE-2024-6162?

The severity of CVE-2024-6162 is high due to potential information leakage and denial of service risks.

2

How do I fix CVE-2024-6162?

To fix CVE-2024-6162, upgrade your Undertow version to 2.3.14.Final or later.

3

What software is affected by CVE-2024-6162?

CVE-2024-6162 affects Undertow versions up to 2.2.33.Final and versions between 2.3.0.Alpha1 and 2.3.14.Final.

4

What are the potential impacts of CVE-2024-6162?

The potential impacts of CVE-2024-6162 include mishandling of URL-encoded request paths, leading to incorrect path information during concurrent requests.

5

What is Undertow in relation to CVE-2024-6162?

Undertow is a web server that is impacted by CVE-2024-6162, which shows vulnerabilities in its AJP listener handling.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203