CVE-2024-6307: WordPress Core < 6.5.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via HTML API
WordPress Core is vulnerable to Stored Cross-Site Scripting via the HTML API in various versions prior to 6.5.5 due to insufficient input sanitization and output escaping on URLs. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/wordpressto a version that resolves this vulnerability.Fixed in 6.1.9+dfsg1-0+deb12u1Fixed in 6.8.7+dfsg1-0+deb13u1Fixed in 6.8.12+dfsg1-0+deb13u1Fixed in 7.1.4+dfsg1-1 - Upgrade
Upgrade
debian/wordpressto a version that resolves this vulnerability.Fixed in 6.1.9+dfsg1-0+deb12u1 - Upgrade
Upgrade
debian/wordpressto a version that resolves this vulnerability.Fixed in 6.5.5+dfsg1-1 - Upgrade
Upgrade
WordPress Coreto a version that resolves this vulnerability.Fixed in 6.5.5 - Compensating control
If immediate patching is not possible, restrict access to WordPress users with contributor-level (and above) permissions to reduce the likelihood of authenticated script injection via the HTML API.
Event History
Frequently Asked Questions
What is the severity of CVE-2024-6307?
CVE-2024-6307 is considered a high-severity vulnerability due to its potential for stored cross-site scripting (XSS) attacks.
How do I fix CVE-2024-6307?
To fix CVE-2024-6307, update your WordPress Core installation to version 6.5.5 or later.
Who is affected by CVE-2024-6307?
CVE-2024-6307 affects authenticated users with contributor-level access and above in versions of WordPress Core prior to 6.5.5.
What kind of attack can CVE-2024-6307 facilitate?
CVE-2024-6307 can facilitate stored cross-site scripting (XSS) attacks that allow attackers to inject malicious scripts into webpages.
What versions of WordPress are vulnerable to CVE-2024-6307?
All versions of WordPress Core prior to 6.5.5 are vulnerable to CVE-2024-6307.