CWE
284
EPSS
0.126%
Advisory Published
Updated

CVE-2024-6385: Improper Access Control in GitLab

First published: Thu Jul 11 2024(Updated: )

An issue was discovered in GitLab CE/EE affecting all versions starting from 15.8 prior to 16.11.6, starting from 17.0 prior to 17.0.4, and starting from 17.1 prior to 17.1.2, which allows an attacker to trigger a pipeline as another user under certain circumstances.

Credit: cve@gitlab.com

Affected SoftwareAffected VersionHow to fix
GitLab GitLab>=15.8.0<16.11.6
GitLab GitLab>=15.8.0<16.11.6
GitLab GitLab>=17.0.0<17.0.4
GitLab GitLab>=17.0.0<17.0.4
GitLab GitLab>=17.1.0<17.1.2
GitLab GitLab>=17.1.0<17.1.2

Remedy

Upgrade to versions 17.1.2, 17.0.4, 16.11.6 or above.

Never miss a vulnerability like this again

Sign up to SecAlerts for real-time vulnerability data matched to your software, aggregated from hundreds of sources.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2024 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203