CVE-2024-7781: Jupiter X Core <= 4.7.5 - Limited Unauthenticated Authentication Bypass to Account Takeover
The Jupiter X Core plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 4.7.5. This is due to improper authentication via the Social Login widget. This makes it possible for unauthenticated attackers to log in as the first user to have logged in with a social media account, including administrator accounts. Attackers can exploit the vulnerability even if the Social Login element has been disabled, as long as it was previously enabled and used. The vulnerability was partially patched in version 4.7.5, and fully patched in version 4.7.8.
Affected Software
Remediation
Patch Available
Event History
Frequently Asked Questions
What is the severity of CVE-2024-7781?
CVE-2024-7781 has a critical severity rating due to the risk of authentication bypass.
How do I fix CVE-2024-7781?
To fix CVE-2024-7781, upgrade the Jupiter X Core plugin to version 4.7.6 or later.
What systems are impacted by CVE-2024-7781?
CVE-2024-7781 affects all versions of the Jupiter X Core plugin for WordPress up to and including 4.7.5.
Who can exploit CVE-2024-7781?
CVE-2024-7781 can be exploited by unauthenticated attackers due to improper authentication mechanisms.
What causes the vulnerability in CVE-2024-7781?
The vulnerability in CVE-2024-7781 is caused by improper authentication via the Social Login widget.